Intermittent linux64-qr TEST-UNEXPECTED-FAIL | file:///home/worker/workspace/build/tests/reftest/tests/layout/reftests/ogg-video/poster-2.html | application terminated with exit code 11 | application crashed [@ mozalloc_abort]

RESOLVED WORKSFORME

Status

()

Core
Graphics: WebRender
P3
normal
RESOLVED WORKSFORME
a year ago
7 months ago

People

(Reporter: kats, Unassigned)

Tracking

(Blocks: 2 bugs, {intermittent-failure})

54 Branch
x86_64
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 affected, firefox56 unaffected, firefox57 unaffected)

Details

(Whiteboard: [gfx-noted][rust_panic:flatten_items])

https://treeherder.mozilla.org/logviewer.html#?job_id=81268577&repo=graphics&lineNumber=6290

thread 'RenderBackend' panicked at 'no entry found for key', /buildslave/rust-buildbot/slave/stable-dist-rustc-linux/build/src/libcore/option.rs:715
stack backtrace:
   1:     0x7f7cc2f9119a - std::sys::imp::backtrace::tracing::imp::write::h3188f035833a2635
   2:     0x7f7cc2f905ef - std::panicking::default_hook::{{closure}}::h6385b6959a2dd25b
   3:     0x7f7cc2f8fc3c - std::panicking::rust_panic_with_hook::hf00b8130f73095ec
   4:     0x7f7cc2f8f7bf - std::panicking::begin_panic::h6227f62cb2cdaeb4
   5:     0x7f7cc2f8f769 - std::panicking::begin_panic_fmt::h173eadd80ae64bec
   6:     0x7f7cc2f9a516 - core::panicking::panic_fmt::h3b2d1e30090844ff
   7:     0x7f7cc2f9f6d7 - core::option::expect_failed::h5acccc61e40ad23f
   8:     0x7f7cc2f34077 - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
   9:     0x7f7cc2f325be - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  10:     0x7f7cc2f2d4f8 - webrender::frame::Frame::flatten_stacking_context::h5dee7bbc613e4479
  11:     0x7f7cc2f32070 - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  12:     0x7f7cc2f325be - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  13:     0x7f7cc2f2d4f8 - webrender::frame::Frame::flatten_stacking_context::h5dee7bbc613e4479
  14:     0x7f7cc2f32070 - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  15:     0x7f7cc2f325be - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  16:     0x7f7cc2f2d4f8 - webrender::frame::Frame::flatten_stacking_context::h5dee7bbc613e4479
  17:     0x7f7cc2f32070 - webrender::frame::Frame::flatten_items::h4502b92dd7225db8
  18:     0x7f7cc2f2d4f8 - webrender::frame::Frame::flatten_stacking_context::h5dee7bbc613e4479
  19:     0x7f7cc2f28c8f - webrender::render_backend::RenderBackend::build_scene::h1a43e07d7cd5b4c5
  20:     0x7f7cc2f1324f - webrender::render_backend::RenderBackend::run::h12c48ce9085dd5bd
  21:     0x7f7cc2f0b34d - <F as alloc::boxed::FnBox<A>>::call_box::h7edba8096fdca8a6
  22:     0x7f7cc2f97d03 - std::sys::imp::thread::Thread::new::thread_start::he018521f53b24939
  23:     0x7f7ccff286b9 - start_thread
  24:     0x7f7ccefb182c - clone
  25:                0x0 - <unknown>
Whiteboard: [gfx-noted][rust_panic] → [gfx-noted][rust_panic:flatten_items]
See Also: → bug 1363347
(Reporter)

Updated

11 months ago
See Also: → bug 1368162
(Reporter)

Updated

11 months ago
See Also: → bug 1370364
(Reporter)

Updated

11 months ago
See Also: bug 1368162
(Reporter)

Updated

11 months ago
Duplicate of this bug: 1368162
Blocks: 1386670
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
I guess we haven't seen this in a while.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.