The default bug view has changed. See this FAQ.

In reader mode, ERT is not translated in the specific build language.

RESOLVED INVALID

Status

()

Toolkit
Reader Mode
RESOLVED INVALID
25 days ago
21 days ago

People

(Reporter: Abid, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

25 days ago
Created attachment 8843388 [details]
Estimated Reader Time in English language only.

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36 OPR/43.0.2442.1144

Steps to reproduce:

Build ID: 20170303004003
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

Steps to reproduce:
1) Open link: https://da.wikipedia.org/wiki/Forside
2) Click on the reader mode icon.


Actual results:

ERT(Estimated Reader Time) does not display in the specific language. 


Expected results:

ERT(Estimated Reader Time) should display in the desired language. Here for example in Danish "x minutter" instead of "x minutes".

Comment 1

25 days ago
Looks fine for https://transvision.mozfr.org/?recherche=estimatedReadTimeValue1&repo=aurora&sourcelocale=en-US&locale=da&search_type=entities.


Work fine in 53.0a2 (2017-02-27) (zh-CN).
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Comment 2

25 days ago
I tried with Nightly in en-US (the default build) on French Win 7, it was displayed in French.

Abid, what's your locale version of Firefox?

If the issue is about missing translation in a specific locale, so it should be triaged into the l10n component.
Flags: needinfo?(rahmanabidkafoo)
(Reporter)

Comment 3

22 days ago
I have found this bug in aurora with English windows 8.1, 64 Bit !

Build ID 	20170303004003
User Agent 	Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
Flags: needinfo?(rahmanabidkafoo)

Comment 4

21 days ago
You need to download a language specific build (as it is mentioned in comment 2) to see that the ERT is translated to that language, otherwise the ERT remaining "minutes" for every language.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 21 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.