Regression Firefox doesn't correctly copy-paste bookmarks sometimes

RESOLVED DUPLICATE of bug 1343256

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 1343256
11 months ago
10 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
I have a problem with Firefox Beta 52. It doesn't happen on Firefox 28.
Sometimes Firefox doesn't correctly copy bookmarks.
It happens unpredictably, however, I noticed one specific scenario when it happens

1. Create new bookmark with name "g - google", url "https://www.google.com/webhp?q=%s", keyword "g"
2. Edit that bookmark: change name to "b - example.org", url to "http://example.org/query?b=%s", keyword to "b"
3. Select that bookmark in bookmarks sidebar, press Ctrl+C, then Ctrl+Z, then Ctrl+V

Result: bookmark "b - example.org" doesn't have keyword
Expected: bookmark "b - example.org" should have keyword "b"

This is a basic trick during text editing, and when you edit text (or other items supporting edit and Ctrl+Z/X/C) a lot, it becomes natural. The worst part of Firefox behavior is that it makes it look like old bookmark is correctly pasted from clipboard, but in fact that bookmark is broken (see above). I lost data several times because of this bug.

Comment 1

11 months ago
I think it's a duplicate of Bug 1343256.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1343256
You need to log in before you can comment on or make changes to this bug.