Wrong size of window contents on restoring session in tiling WM

RESOLVED DUPLICATE of bug 686747

Status

()

Firefox
Session Restore
--
minor
RESOLVED DUPLICATE of bug 686747
a year ago
10 months ago

People

(Reporter: frank.sandow, Unassigned)

Tracking

51 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8843698 [details]
Only left half of the window is functional

I use i3wm on ArchLinux 64bit (tiling window manager). Firefox version 51.0.1 (64-bit).
Steps to reproduce:
1. Close Firefox when it fills part of the screen
2. Reopen Firefox on empty workspace. After restoring session avaliable working space would be limited to previous session window size.

Expected behavior:
After restoring session the window would fill current window size

I attached a screenshot of the problem.
It would seem that Firefox attemts to restore previous window size and ignores set window size. This behaviour was reproduced on new profile.
(Reporter)

Comment 1

a year ago
I forgot to mention that to fix this behaviour you can just resize the window.

Comment 2

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

I can also confirm that this issue is still present in Firefox Nightly 55.0a1 on Arch Linux.
I'm using a custom fork of dwm called btdwm (https://github.com/teeuwen/btdwm).

Comment 3

10 months ago
Created attachment 8860416 [details]
clicking actions do correspond to the correct location, the window is just incorrectly rendered

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686747
You need to log in before you can comment on or make changes to this bug.