Dropdown menu list is completely unreadable due to broken style caused by patches from bug #910022

VERIFIED FIXED in Firefox 54

Status

()

defect
--
major
VERIFIED FIXED
3 years ago
3 months ago

People

(Reporter: Virtual, Assigned: jaws)

Tracking

(Blocks 1 bug, 4 keywords)

54 Branch
mozilla55
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox51 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54+ verified, firefox55+ verified)

Details

()

Attachments

(3 attachments)

[Tracking Requested - why for this release]: Regression

STR:
1. Open this URL - https://www.redisbad.pl/app_fiscal.php/husaria-szarza-nadruk-sublimacyjny
2. Select one of two dropdown buttons to see dropdown menu list
3. and see that it's mostly unreadable due to broken style

either there should be:
-normal system style like black text fonts and white background (like in Firefox 53)
-normal website style like white text fonts and black background (fixing current state + with dropdown button
Flags: needinfo?(jaws)
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #0)
> + with dropdown button style
fixed
Tracking 54+ for this visible regression.
I've got a patch that should fix this. Just need to finish writing the new test.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Tracking 55+ for this regression.
Comment on attachment 8844119 [details]
Bug 1344574 - Compare the option foreground color to the used select background color instead of just the user-agent default select background color.

https://reviewboard.mozilla.org/r/117656/#review119816

Thanks! Don't forget to get your uplift requested.
Attachment #8844119 - Flags: review?(mconley) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9011255607e3
Compare the option foreground color to the used select background color instead of just the user-agent default select background color. r=mconley
Comment on attachment 8844119 [details]
Bug 1344574 - Compare the option foreground color to the used select background color instead of just the user-agent default select background color.

Approval Request Comment
[Feature/Bug causing the regression]: missed a case as part of bug 910022
[User impact if declined]: <select> menus on some pages may be unreadable
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: just landed on autoland, should be in Nightly within 2 days
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no, simple fix covered by tests
[Why is the change risky/not risky?]: see above answer
[String changes made/needed]: none
Attachment #8844119 - Flags: approval-mozilla-aurora?
Blocks: 910022
Has Regression Range: --- → yes
Summary: Dropdown menu list is using completely unreadable due to broken style in Firefox 54 → Dropdown menu list is completely unreadable due to broken style caused by patches from bug #910022
https://hg.mozilla.org/mozilla-central/rev/9011255607e3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
@ Gerry Chang [:gchang] - No need to, as reporter of this issue, I will do it. ;)
Flags: needinfo?(brindusa.tot)
I'm marking this bug as VERIFIED,
because starting from Mozilla Firefox Nightly 55.0a1 (2017-03-09) the issue is fixed.
Status: RESOLVED → VERIFIED
Comment on attachment 8844119 [details]
Bug 1344574 - Compare the option foreground color to the used select background color instead of just the user-agent default select background color.

Fix a unreadable dropdown menu regression and was verified. Aurora54+.
Attachment #8844119 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.