Assertion: GetTableRowGroupFrame()-> GetTableFrame()->IsDeletedRowIndexRangesEmpty() [@ nsTableRowFrame::SetRowIndex]

RESOLVED DUPLICATE of bug 1344628

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 1344628
a year ago
a year ago

People

(Reporter: tsmith, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
assertion, testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8843781 [details]
test_case.html

Assertion failure: GetTableRowGroupFrame()-> GetTableFrame()->IsDeletedRowIndexRangesEmpty() (mDeletedRowIndexRanges should be empty here!), at /home/worker/workspace/build/src/layout/tables/nsTableRowFrame.h:355

#0 0x7f011a9c15fb in nsTableRowFrame::SetRowIndex(int) /home/worker/workspace/build/src/layout/tables/nsTableRowFrame.h:353:3
    #1 0x7f011a9c1433 in nsTableFrame::ResetRowIndices(nsFrameList::Slice const&) /home/worker/workspace/build/src/layout/tables/nsTableFrame.cpp:534:11
    #2 0x7f011a9d5115 in nsTableFrame::DoRemoveFrame(mozilla::layout::FrameChildListID, nsIFrame*) /home/worker/workspace/build/src/layout/tables/nsTableFrame.cpp:2720:7
    #3 0x7f011a9d54a2 in nsTableFrame::RemoveFrame(mozilla::layout::FrameChildListID, nsIFrame*) /home/worker/workspace/build/src/layout/tables/nsTableFrame.cpp:2745:5
    #4 0x7f011a640b64 in nsFrameManager::RemoveFrame(mozilla::layout::FrameChildListID, nsIFrame*) /home/worker/workspace/build/src/layout/base/nsFrameManager.cpp:525:5
    #5 0x7f011a63ef37 in nsCSSFrameConstructor::ContentRemoved(nsIContent*, nsIContent*, nsIContent*, nsCSSFrameConstructor::RemoveFlags, bool*, nsIContent**) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:8570:5
    #6 0x7f011a6344a2 in nsCSSFrameConstructor::RecreateFramesForContent(nsIContent*, bool, nsCSSFrameConstructor::RemoveFlags, nsIContent**) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:9759:10
    #7 0x7f011a63d821 in nsCSSFrameConstructor::WipeContainingBlock(nsFrameConstructorState&, nsIFrame*, nsIFrame*, nsCSSFrameConstructor::FrameConstructionItemList&, bool, nsIFrame*) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:12356:5
    #8 0x7f011a63b604 in nsCSSFrameConstructor::ContentAppended(nsIContent*, nsIContent*, bool) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7540:7
    #9 0x7f011a63863c in nsCSSFrameConstructor::CreateNeededFrames(nsIContent*) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7183:5
    #10 0x7f011a63866a in nsCSSFrameConstructor::CreateNeededFrames(nsIContent*) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7190:7
    #11 0x7f011a63866a in nsCSSFrameConstructor::CreateNeededFrames(nsIContent*) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7190:7
    #12 0x7f011a63866a in nsCSSFrameConstructor::CreateNeededFrames(nsIContent*) /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7190:7
    #13 0x7f011a63bdb0 in nsCSSFrameConstructor::CreateNeededFrames() /home/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:7205:5
    #14 0x7f011a586abd in mozilla::GeckoRestyleManager::ProcessPendingRestyles() /home/worker/workspace/build/src/layout/base/GeckoRestyleManager.cpp:464:3
    #15 0x7f011a5bd1a7 in mozilla::PresShell::DoFlushPendingNotifications(mozilla::ChangesToFlush) /home/worker/workspace/build/src/layout/base/PresShell.cpp:4184:9
    #16 0x7f011a5bcac1 in mozilla::PresShell::DoFlushPendingNotifications(mozilla::FlushType) /home/worker/workspace/build/src/layout/base/PresShell.cpp:4060:3
    #17 0x7f0117339ca3 in nsDocument::FlushPendingNotifications(mozilla::FlushType) /home/worker/workspace/build/src/dom/base/nsDocument.cpp:7984:5
    #18 0x7f01166493d1 in nsDocLoader::DocLoaderIsEmpty(bool) /home/worker/workspace/build/src/uriloader/base/nsDocLoader.cpp:685:9
    #19 0x7f011664ad60 in nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult) /home/worker/workspace/build/src/uriloader/base/nsDocLoader.cpp:614:5
    #20 0x7f011664b72c in non-virtual thunk to nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult) /home/worker/workspace/build/src/uriloader/base/nsDocLoader.cpp:470:14
    #21 0x7f01153d67eb in mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, nsresult) /home/worker/workspace/build/src/netwerk/base/nsLoadGroup.cpp:634:18
    #22 0x7f011733e96b in nsDocument::DoUnblockOnload() /home/worker/workspace/build/src/dom/base/nsDocument.cpp:8840:7
    #23 0x7f011733e67a in nsDocument::UnblockOnload(bool) /home/worker/workspace/build/src/dom/base/nsDocument.cpp:8766:9
    #24 0x7f0117322f7e in nsDocument::DispatchContentLoadedEvents() /home/worker/workspace/build/src/dom/base/nsDocument.cpp:5293:3
    #25 0x7f01173b80b4 in mozilla::detail::RunnableMethodImpl<nsDocument*, void (nsDocument::*)(), true, false>::Run() /home/worker/workspace/build/src/obj-firefox/dist/include/nsThreadUtils.h:890:7
    #26 0x7f0115239f45 in nsThread::ProcessNextEvent(bool, bool*) /home/worker/workspace/build/src/xpcom/threads/nsThread.cpp:1264:7
    #27 0x7f01152365e0 in NS_ProcessNextEvent(nsIThread*, bool) /home/worker/workspace/build/src/xpcom/threads/nsThreadUtils.cpp:389:10
    #28 0x7f0115d4c6f9 in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) /home/worker/workspace/build/src/ipc/glue/MessagePump.cpp:96:21
    #29 0x7f0115cb82f7 in MessageLoop::RunInternal() /home/worker/workspace/build/src/ipc/chromium/src/base/message_loop.cc:238:3
    #30 0x7f0115cb8189 in MessageLoop::Run() /home/worker/workspace/build/src/ipc/chromium/src/base/message_loop.cc:211:3
    #31 0x7f011a09d56a in nsBaseAppShell::Run() /home/worker/workspace/build/src/widget/nsBaseAppShell.cpp:156:3
    #32 0x7f011ca5c2ac in nsAppStartup::Run() /home/worker/workspace/build/src/toolkit/components/startup/nsAppStartup.cpp:283:19
    #33 0x7f011cba7129 in XREMain::XRE_mainRun() /home/worker/workspace/build/src/toolkit/xre/nsAppRunner.cpp:4476:10
    #34 0x7f011cba8cb7 in XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) /home/worker/workspace/build/src/toolkit/xre/nsAppRunner.cpp:4654:8
    #35 0x7f011cba9b02 in XRE_main(int, char**, mozilla::BootstrapConfig const&) /home/worker/workspace/build/src/toolkit/xre/nsAppRunner.cpp:4745:16
    #36 0x4e0e23 in do_main(int, char**, char**) /home/worker/workspace/build/src/browser/app/nsBrowserApp.cpp:236:10
    #37 0x4e06a0 in main /home/worker/workspace/build/src/browser/app/nsBrowserApp.cpp:307:16
    #38 0x7f0130c5482f in __libc_start_main /build/glibc-t3gR2i/glibc-2.23/csu/../csu/libc-start.c:291
    #39 0x41ccd4 in _start (/home/user/workspace/browsers/firefox_dbg/firefox+0x41ccd4)
(Reporter)

Updated

a year ago
Flags: in-testsuite?
I can't reproduce this assertion in an up-to-date m-i debug build on Linux,
so I'm pretty sure it was fixed by bug 1344628.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1344628
You need to log in before you can comment on or make changes to this bug.