saving page with file name from foreign http server

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
17 years ago
2 years ago

People

(Reporter: budew, Assigned: samir_bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    0.9.9

Terse:  Sorry, this is a feature request, but I don't want to join all the
newsgroups just for this:

Appears in both 0.9.8 and 0.9.9.  When saving any web page I've tried, the
browser presents as the default name of the new file on my home machine the file
name that the foreign web page server uses on the sending computer (what good is
that to me?); it should instead present the *title* of the web page, the one
that is shown in the very top title bar of all? the browsers - in other words, a
file name that descriptively means something to the *human* user saving the page
(so I don't have to retype a name, or proactively copy it out of the article
before saving so I can paste it in the file name entry box when that pops up). 
Thank you for the browser; otherwise pretty neat.

Reproducible: Always
Steps to Reproduce:
1.Use browser in Win2K
2.Save any page you choose to your own hard drive
3.You'll have to type in a meaningful-to-user title; the default will be the
file system name from the foreign, server computer web site directory

Expected Results:  Present as the default "file name Save As", the title of the
page, usually seen in the top title bar of the browser, and I'm supposing it
gets it from the "<title>  </title>" section of the web page.
We had this.  It was not well-received.  See bug 115176.
Assignee: mpt → sgehani
Component: User Interface Design → XP Apps
QA Contact: zach → paw

Comment 2

17 years ago
dupe per bz' comment

*** This bug has been marked as a duplicate of 115176 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Not a dupe. We had this behavior in 0.9.7, and 115176 was about removing it.
This bug is the opposite of 115176. Reopening and suggesting WONTFIX.
Severity: minor → enhancement
Status: RESOLVED → UNCONFIRMED
Component: XP Apps → File Handling
Resolution: DUPLICATE → ---

Comment 4

17 years ago
Marking WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
*** Bug 155997 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.