First sync is not automatically initialized if the sign in needed confirmation

RESOLVED DUPLICATE of bug 1345597

Status

()

Firefox for iOS
Sync
RESOLVED DUPLICATE of bug 1345597
10 months ago
9 months ago

People

(Reporter: csuciu, Unassigned)

Tracking

({reproducible})

unspecified
Other
iOS
reproducible

Firefox Tracking Flags

(fxios7.1+, fxios-v7.0 affected)

Details

(Reporter)

Description

10 months ago
Firefox Beta 7.0 (1893)

1. Go to Firefox settings and login into sync with an existing account which was not used recently (in the last hour).
2. Confirm the sign in using the emailed confirmation link. 
3. Check the sync section in the Firefox settings page.

Expected: The sync should automatically start after confirming the sign in.

Actual: First sync is not automatically initialized.

Note: If the sign in does not need confirmation, first sync works as expected. It's automatically initialized after logging in.

Comment 1

10 months ago
Regression?

Comment 2

10 months ago
I can reproduce on my iPad. This needs investigation in 7.0.
Flags: needinfo?(sleroux)
Keywords: reproducible

Updated

10 months ago
Depends on: 1345597
See https://bugzilla.mozilla.org/show_bug.cgi?id=1345597 for root cause.
Flags: needinfo?(sleroux)

Updated

9 months ago
tracking-fxios: ? → 7.1+

Updated

9 months ago
Alias: sync-hosed

Updated

9 months ago
Alias: sync-hosed

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345597
You need to log in before you can comment on or make changes to this bug.