[DOGFOOD] [PP] Linux: Backspace and Delete insert spaces

VERIFIED FIXED in M11

Status

()

defect
P1
major
VERIFIED FIXED
20 years ago
18 years ago

People

(Reporter: cpratt, Assigned: akkzilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Build ID: 1999090908
Platform: RH Linux 6 (only)

To reproduce:
- Launch apprunner
- Click to the right of the URL in the Location: control
- Press Backspace a few times

Result: Spaces are inserted and the caret moves to the right

- Now, click somewhere in the middle of the URL
- Press the Delete key a few times

Result: Characters to the right of the caret are replaced by white space

Expected result: Backspace should move the caret to the left while deleting
characters; Delete should delete the character to the right of the caret while
moving the rest of the text on the line to the left.
Assignee: trudelle → buster
Component: XP Toolkit/Widgets → Editor
Reproduced, but only in Ender text widget. changing component to
editor, reassigning to buster

QA: Please take note that text neither text edit widgets nor HTML forms controls
are XPToolkit widgets!
I hadn't realized that was an Editor problem. All I know is this: if you change
the Debug prefs to use GFX, everything breaks in the browser (the Location:
control etc.).
Assignee: buster → akkana
Summary: [PP] Linux - Backspace and Delete not working in Location: → [DOGFOOD] [PP] Linux - Backspace and Delete not working in Location:
Target Milestone: M11
akkana, can you see what's going on here in linux?  I don't see it on windows
at all.
I can't tell if this is a display problem, or a content manipulation problem, or
a keyboard event handling problem?  Are we getting the right commands
(backspace, delete)?  If so, are we manipulating the content correctly (that
should be 100% XP)?  If so, is it just a painting/update problem?
Once you can categorize the problem, please assign to the appropriate person.
Marked dogfood since this certainly would keep people from using the app.
Assignee: akkana → pavlov
No, we're never getting the event.  This is because of the XIM code, which
Pavlov just changed.  Reassigning to Pavlov, but meanwhile I'll look into what
we need to change to back this out.  Unfortunately, commenting out the -DUSE_XIM
in the widget/src/gtk Makefile.in causes worse problems (the apprunner window
doesn't even come up).
QA Contact: beppe → phillip
Changing QA Contact (sorry, phillip!).
Changing the USE_XIM on line 704 of nsGtkEventHandler.cpp to USE_XIM_NOT fixes
this problem (but, of course, disables whatever it is that XIM is supposed to be
doing with those keys).
I've checked in the workaround.
*** Bug 13467 has been marked as a duplicate of this bug. ***
Whiteboard: workaround checked in. working on fix
Priority: P3 → P2
This is broken for me tonight.  P2.
Priority: P2 → P1
Summary: [DOGFOOD] [PP] Linux - Backspace and Delete not working in Location: → [DOGFOOD] [PP] Linux: Backspace and Delete insert spaces
URL bar, text fields, text areas.  This is really broken.
P1.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
This is working for me, marking so.
QA, this might not show up until Tuesday's build.
Still broken in the 1999092013 build on Linux. btw, I would have marked this
FIXED and not worksforme; please bear in mind that a QA person's review often
contains information about how many of their bugs were judged to be not a bug,
ie worksforme. Thanks!
Status: RESOLVED → REOPENED
Whiteboard: workaround checked in. working on fix
Assignee: pavlov → akkana
Status: REOPENED → NEW
Status: NEW → ASSIGNED
I agree, this bug has come back, probably as a result of Steve's change to the
editor event listeners to work around a bug in the Windows event handler.  Turns
out the gtk key handler is sending both keycode and charcode for these events.
I'm working on a fix.
Resolution: WORKSFORME → ---
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Checked in a fix for the regression: the gtk event handler now sends key code or
char code, but never both, and backspace and delete events are being handled
properly now.
Depends on: 14395
No longer depends on: 14395
QA Contact: phillip → cpratt
assigning Pratt as QA contact
Status: RESOLVED → VERIFIED
Verified fixed in the 1999092708 build, Linux.
You need to log in before you can comment on or make changes to this bug.