Status

()

Firefox for Android
General
--
blocker
RESOLVED DUPLICATE of bug 1356563
3 months ago
a month ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170210223443

Steps to reproduce:

Either ask to reload a page or try to open a page from the history.


Actual results:

I get an orange bar below the address bar on the left of the screen (about 20% the width of the screen). If I try to reload a page, nothing else happens. A force reload can give a blank page. And when I choose a page from the history, the URL doesn't even appear in the address bar.


Expected results:

The page should load.

Notes: No such problem with Google Chrome. I have the latest Firefox Beta version (4.3). The "about:" page is blank.
(Reporter)

Updated

3 months ago
Severity: normal → blocker

Comment 1

3 months ago
Can you get a logcat for this behaviour? Use |adb logcat -dv threadtime | grep Gecko > log.txt| [1] when this is happening and attach the log to this bug.

Also, how did this happen? Was Firefox working normally and then it suddenly stopped working during browsing, or were things broken directly after starting Firefox? Is this consistently happening every time you start Firefox, or just randomly?

[1] ADB available from here (https://developer.android.com/studio/releases/platform-tools.html) if necessary.
(Reporter)

Comment 2

3 months ago
The problem currently no longer occurs (I haven't even restarted Firefox).

(In reply to Jan Henning [:JanH] from comment #1)
> Also, how did this happen? Was Firefox working normally and then it suddenly
> stopped working during browsing, or were things broken directly after
> starting Firefox?

I hadn't used Firefox since yesterday, and it was working correctly at that time (but I'm not sure whether it was upgraded in the mean time, Google Play just tells me that it was recently updated with 4 other apps). And when I used my phone again a few hours after getting this problem, Firefox was working normally.

Comment 3

3 months ago
The symptoms sound like Gecko was somehow temporarily blocked on something or slow to load, but without a log it's hard to say why exactly. Since you said that Firefox had recently updated, maybe something related to bug 1298090 was taking longer than expected, but that's just guessing.

There's also bug 1332198, which described similar symptoms...
See Also: → bug 1332198
(Reporter)

Comment 4

3 months ago
Isn't it possible to get logs of what happened when the problem occurred (similar to syslog or the systemd journal under GNU/Linux)? Or the update date of the app?

Updated

a month ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1356563
You need to log in before you can comment on or make changes to this bug.