Firefox 52 cannot output sound in Fedora Core 25 x64 (Pulse Audio related)

RESOLVED DUPLICATE of bug 1345661

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1345661
a year ago
10 months ago

People

(Reporter: Artem S. Tashkinov, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

Installed Firefox from https://ftp.mozilla.org/pub/firefox/releases/52.0/linux-x86_64-EME-free/en-US/firefox-52.0.tar.bz2

Tried to play youtube video. Firefox says: 

To play audio, you may need to install the required PulseAudio software.

When I click the "Learn How" button I'm redirected to the dead page:

https://support.mozilla.org/1/firefox/52.0/Linux/en-US/fix-common-audio-and-video-issues

$ strings libxul.so | grep pulse
libpulse.so.0
,libpulse %s
http://home.netscape.com/NC-rdf#pulse
cannot-initialize-pulseaudio
pulse
libpulse.so.0
collegepulse.org
dipulse.it
/builds/slave/m-rel-l64-00000000000000000000/build/src/media/libcubeb/src/cubeb_pulse.c
pulse_context_init
pulse_get_max_channel_count
pulse_get_preferred_sample_rate
pulse_stream_init
pulse_stream_get_latency
pulse_init

$ ls -l /usr/lib64/libpulse.so.0
lrwxrwxrwx. 1 root root 18 Jan 19 16:52 /usr/lib64/libpulse.so.0 -> libpulse.so.0.20.1

So, what am I missing?
(Reporter)

Comment 1

a year ago
There's nothing in the console.

The internal developer console has a single nondescript message:

"Unable to use PulseAudio".

Guys, why are you so hell bent on breaking something that worked fine and now looks and acts like a pile of shat?

This is by far the worst release of Firefox in my memory. And you dare to call it ESR. That's insane.
(Reporter)

Comment 2

a year ago
OK, let's cut the BS:

1) PulseAudio is NOT a hard requirement in any existing Linux distro.
2) Though most applications are compiled with PA support, pretty much all of them can play directly via ALSA (sans Skype).

Please, give us ALSA back. I haven't seen any bug reports or problems related to ALSA, so why would you suddenly deprecate it?
(Reporter)

Comment 3

a year ago
Right now Firefox 52 under apulse (ALSA PulseAudio emulation layer) crashes ( https://github.com/i-rinat/apulse/issues/43 ) but hopefully the developer will fix this problem.
(Reporter)

Comment 4

a year ago
Feel free to close this bug report as INVALID/WONTFIX.

I do understand you won't backtrack and you just LOVE to make Linux users' lives harder.

In fact given that ALL status bar add-ons make Firefox 52 unusable you just actively HATE your users.

Viva, Mozilla. Kill Firefox faster!
(Reporter)

Comment 5

a year ago
OK, apulse actually works just fine.

I'm closing this bug report as WONTFIX because no one at Mozilla gives a **** anyways.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Updated

a year ago
Blocks: 1345661

Comment 6

a year ago
I wonder what the hell is going on here. I'm Mozilla user since Netscape Navigator. Broken ALSA is the worst change in the Netscape/Mozilla/Firefox I have ever had. Why do you want to get rid of your loyal users? Firefox market share is decreasing day after day and someone decided to decrease it even faster. Who in Mozilla is responsible for this mess?
(Reporter)

Comment 7

a year ago
According to Mozilla's internal stats less then 3% of Linux users use ALSA directly that's why they decided to part ways with it. Also ALSA makes it very difficult to properly sandbox/isolate Firefox.

Since apulse (https://github.com/i-rinat/apulse) works just fine I guess there's nothing to whine about.

Comments like this won't make Mozilla change their stance - they welcome patches and you're free to compile Firefox with ALSA from sources.

Comment 8

a year ago
ALSA has been disabled by default in Debian packages. I know how to re-build Firefox from sources it is not convenient for me. The primary problem is that the latest Flash Player doesn't support PulseAudio. I can hear some sounds from Flash Player via ALSA->PulseAudio->ALSA emulation, but microphone doesn't work at all. As you can understand, now I have to choose between working Flash Player and working HTML audio. Of course, Flash Play must die, but I can't fully avoid it right now.

Comment 9

a year ago
(In reply to Artem S. Tashkinov from comment #7)

The reason seems to be that mozilla dev had not maintained their own alsa code and it was lacking features they want such as full duplex and 5.1, their alsa implementation also gives a hard time with their upcoming sandboxing effort as you pointed out. 
Instead of fixing their own code for some reason they decided, despite being warned that it would lose them users and upset people, to drop alsa support and make a hard dependency on pulseaudio to be able to play sound in firefox on Linux.

Since the **** hit the fan a couple people volunteered to fix and maintain their alsa code but the dev answer had been that even with this alsa is not planned to make a come back in any foreseeable future.

User feedback indicates that apulse works for some and does not for others, there are a number of things not working when using apulse because it is a partial API implementation and never intended to fully implement the pulseaudio API, see Audio capture in Firefox doesn't work[1] for example. So apulse is not an acceptable work around. 

Compiling from source with alsa support will stop working with firefox 54 when the alsa code is stripped from firefox. So this is not a viable solution either.

AS forecast a year ago[2], currently there's really only one choice: install pulseaudio or switch to a different browser, of all linux web browsers firefox is the only one without alsa support and a hard dependency on pulseaudio.

[1]: https://github.com/i-rinat/apulse/issues/49
[2]: https://bugzilla.mozilla.org/show_bug.cgi?id=1247056#c7

Comment 10

a year ago
(In reply to Roman Tsisyk from comment #8)
> ALSA has been disabled by default in Debian packages.

Debian builds 52 ESR with ALSA enabled, so you can use that.

> The primary problem is that the latest Flash Player doesn't support
> PulseAudio. I can hear some sounds from Flash Player via
> ALSA->PulseAudio->ALSA emulation, but microphone doesn't work at all.
> As you can understand, now I have to choose between working Flash
> Player and working HTML audio.

There is a package in Debian, named browser-plugin-freshplayer-pepperflash.
It acts as a bridge between Firefox and PepperFlash (the flavor used by
Chrome). It has dedicated code to playback and capture through PulseAudio,
without ALSA->PulseAudio->ALSA emulation you mentioned.
No longer blocks: 1345661
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1345661
You need to log in before you can comment on or make changes to this bug.