Closed Bug 1345229 Opened 4 years ago Closed 2 years ago

Emoji show two dots as a mask in password fields

Categories

(Core :: DOM: Editor, defect, P3)

52 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 780449
Tracking Status
firefox54 --- affected

People

(Reporter: jonnew, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image password-poo.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3018.3 Safari/537.36

Steps to reproduce:

Paste "
Ugh, the bugzilla form fields don't handle emoji!  Let's try again.

Steps to reproduce:
Copy a poo emoji from https://codepoints.net/U+1F4A9?lang=en into a password field.

Actual results:
I see two dots in the password field. See attachment.

Expected results:
I see only one dot in the password field.
Thanks for the report.

Relevant code is mozilla::TextEditRules::FillBufWithPWChars(nsAString_internal *, int32_t):
https://dxr.mozilla.org/mozilla-central/search?q=%2Bcallers%3A%22mozilla%3A%3ATextEditRules%3A%3AFillBufWithPWChars%28nsAString_internal+%2A%2C+int32_t%29%22

Testcase is in the URL field.

Confirmed on Nightly 54.
Status: UNCONFIRMED → NEW
Component: Untriaged → Editor
Ever confirmed: true
Product: Firefox → Core
Summary: Emoji show two dots in password fields. → Emoji show two dots as a mask in password fields
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780449
You need to log in before you can comment on or make changes to this bug.