Label of <option> element is not displayed in standards mode

RESOLVED DUPLICATE of bug 40545

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 40545
8 months ago
8 months ago

People

(Reporter: Chris, Unassigned)

Tracking

({testcase})

55 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170307030205

Steps to reproduce:

Go to:
http://jsbin.com/lodayapaxa/1/edit?html,output

Notice the value displayed for the currently selected option element.


Actual results:

In Firefox, the currently selected option element has no displayed value (i.e. the label is ignored, even though we are not in quirks mode).


Expected results:

In Safari and Chrome, it displays 'Y', which is the label of the option element.

This is as per specification:
- https://html.spec.whatwg.org/multipage/rendering.html#the-select-element-2

Note that you should probably still ignore the label in quirks mode to match Chrome and soon WebKit:
- https://bugs.webkit.org/show_bug.cgi?id=169296

Updated

8 months ago
Component: Untriaged → Layout: Form Controls
Keywords: testcase
Product: Firefox → Core
> Note that you should probably still ignore the label in quirks mode

Sounds like that needs a spec bug...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 40545
You need to log in before you can comment on or make changes to this bug.