Always try accessing pages using https

RESOLVED DUPLICATE of bug 1158191

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 1158191
a year ago
a year ago

People

(Reporter: sedrubal, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170126153103

Steps to reproduce:

Clear all your history and bookmarks. Type in "example.com" into the location bar.


Actual results:

Firefox tries to access "http://example.com/"


Expected results:

Firefox should try to access "https://example.com". If ff can't establish a secure connection to example.com it should try to access "http://example.com/"
(Reporter)

Updated

a year ago
Severity: normal → enhancement
Component: Untriaged → Location Bar
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Comment 1

a year ago
Related / possible duplicates: bug 902338, bug 902582, bug 1341350, bug 1343901

This feature request is a bit more strict than the others. This might not be possible today, but when most web pages out there are accessible through https.

The biggest problem I see is that falling back to http pages will take twice as long as accessing them directly.
Another problem is that there might be pages out there serving different content on https/http. But imho it's their problem.

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158191
(In reply to sedrubal from comment #1)
> Another problem is that there might be pages out there serving different
> content on https/http. But imho it's their problem.

It's actually a problem of any user of those pages. That may be millions of people.
You need to log in before you can comment on or make changes to this bug.