Incorrect URL for PulseAudio issues

RESOLVED FIXED

Status

defect
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: pmenzel+bugzilla.mozilla.org, Unassigned)

Tracking

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170308122311

Steps to reproduce:

Upgrade from 51.0.1 to 52.0, and start a Web page to play sound like Soundcloud or YouTube.


Actual results:

The audio does not work. A “pop up” is shown saying that there might be issues with PulseAudio, and if I want to learn more about that issue. Clicking on the button opens the URL https://support.mozilla.org/1/firefox/52.0/Linux/en-US/fix-common-audio-and-video-issues, which does not work.


Expected results:

The URL should be of a Web page actually having information about PulseAudio.
The exact wording is below.

> To play audio, you may need to install the required PulseAudio software. <button>Learn how</button>
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Untriaged → Knowledge Base Content
Ever confirmed: true
Product: Firefox → support.mozilla.org
Version: 52 Branch → unspecified
Blocks: 1247056
Pop-up message is too generic to be useful given that PulseAudio packages vary a lot from different Linux distributions (there is the server package, gstreamer audio plugins, stand-alone libraries...) so which one is needed is a mistery for most of the users. 

Also, the message itself remembers a lot the old dark times when a plugin was required to play some multimedia content, something that html5 video/audio was aimed to avoid and is back again.
The URL that actually works is here https://support.mozilla.org/t5/Videos-sound-pictures-and/Fix-common-audio-and-video-issues/ta-p/401#w_you-may-need-to-install-the-required-pulseaudio-software 

But it is still quite useless as it doesn't offer any help for those who do not want pulseaudio or experience issues with it. Helpful and useful information can be found on the arch wiki: https://wiki.archlinux.org/index.php/PulseAudio/Examples#PulseAudio_as_a_minimal_unintrusive_dumb_pipe_to_ALSA
jsavage, any chance a redirect from https://support.mozilla.org/1/firefox/52.0/Linux/en-US/fix-common-audio-and-video-issues to https://support.mozilla.org/t5/Videos-sound-pictures-and/Fix-common-audio-and-video-issues/ta-p/401#w_you-may-need-to-install-the-required-pulseaudio-software could be put in place?

It looks pretty bad that the in-product URL doesn't work, especially when the users who are affected are pretty unhappy with the product change to begin with.
Flags: needinfo?(jsavage)
Product: support.mozilla.org → support.mozilla.org - Lithium
We've given Lithium a spreadsheet of all in-product redirects and they've implemented it on Stage. We're waiting to see QA results from that.
Flags: needinfo?(jsavage)
Component: Knowledge Base Content → General
Where are we with this bug? It seems things are still broken at the moment (I tested the URL shipped in an up-to-date Firefox 52 ESR).
Flags: needinfo?(jsavage)
We've moved back to the old platform temporarily. I've set up the redirect so it should be working now.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jsavage)
Resolution: --- → FIXED
(For the record)
The KB article on the Kitsune platform is here: https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

When we move back to Lithium, this article has to be recreated since it's currently missing in Lithium (bug 1370422) 
and https://hwsfp35778.lithium.com/t5/Videos-sound-pictures-and/Fix-common-audio-and-video-issues/ta-p/401 produces a "permanently deleted" error. This article is #68 in the spreadsheet that's linked from the bug report.
See Also: → 1370422
You need to log in before you can comment on or make changes to this bug.