Open Bug 1345441 Opened 6 years ago Updated 5 years ago

Regression Reader button in location bar flashes when I open reader view

Categories

(Toolkit :: Reader Mode, defect, P4)

52 Branch
defect

Tracking

()

REOPENED
Tracking Status
firefox52 --- wontfix
firefox53 --- affected
firefox54 --- affected
firefox55 --- affected
firefox56 --- affected

People

(Reporter: 684sigma, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

I have a problem with Firefox Beta 52. It doesn't happen in Firefox ESR 45.
Sometimes when I open reader view, Reader button in location bar hides for a moment and shows up again.
It happens unpredictably, however, I noticed one specific scenario when it happens

1. Open http://www.bbc.com/news/world-asia-39189381
2. Click reader button in location bar

Result: Reader button in location bar hides for a moment and shows up again
Expected: Reader button should be constantly displayed in location bar since I click it. It's best from the user perspective, because I already clicked reader button, and it'll open reader view for sure (possibly with error). Therefore there's no need to hide it for fraction of second.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Component: Untriaged → Reader Mode
Ever confirmed: true
Product: Firefox → Toolkit
Mass wontfix for bugs affecting firefox 52.
Can't reproduce, so closing as wfm. We can reopen if/when more reliable steps to reproduce exist.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
The problem still exists.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Attached image screenrecord (obsolete) —
(In reply to YF (Yang) from comment #3)
> The problem still exists.

The screencast is really small, has no cursor displayed, and, because it's a gif, it auto-repeats, making it really hard to see what's happening. Some questions, then:

1) what version of Firefox is this?
2) what exact steps are you following here, and what are the consequences in the content pane - does reader mode load and are you just clicking it again soon (or is the gif cycling), or does it reload in some way and not actually enter reader mode?
3) does the same thing happen with e10s on/off?
4) does this happen with all articles on the bbc's website for you?

(FWIW, I tried beta and nightly on osx, and can't reproduce on either)
Flags: needinfo?(yfdyh000)
Priority: -- → P4
Attached image larger screenrecord.gif
Attachment #8883888 - Attachment is obsolete: true
(In reply to :Gijs from comment #5)
> (In reply to YF (Yang) from comment #3)
> > The problem still exists.
> 
> The screencast is really small, has no cursor displayed, and, because it's a
> gif, it auto-repeats, making it really hard to see what's happening. Some
> questions, then:
> 
> 1) what version of Firefox is this?
> 2) what exact steps are you following here, and what are the consequences in
> the content pane - does reader mode load and are you just clicking it again
> soon (or is the gif cycling), or does it reload in some way and not actually
> enter reader mode?
> 3) does the same thing happen with e10s on/off?
> 4) does this happen with all articles on the bbc's website for you?
> 
> (FWIW, I tried beta and nightly on osx, and can't reproduce on either)

1. The issue exists in Fx52 to latest Nightly.
2. see the attachment.
3. appears in both.
4. also appears on http://www.bbc.com/news/world-asia-40513334.
5. Windows 10 (1703) x64.
Flags: needinfo?(yfdyh000)
You need to log in before you can comment on or make changes to this bug.