Ctrl + K search shortcut broken for hidden searchbar

RESOLVED DUPLICATE of bug 1315328

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1315328
a year ago
10 months ago

People

(Reporter: Matthijs Tijink, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170308094037

Steps to reproduce:

1. Hide the search bar from the menu and toolbar
2. Press Ctrl + K


Actual results:

The location bar was given input focus, and its current text highlighted (as if Ctrl + L was pressed)


Expected results:

In previous versions, the "home page" was opened, and the searchbar was given input focus.

Based on #1183286, I think this change may have been intentional, but this actually is a regression for me: "Ctrl + L" works identically, so a new shortcut is unneccessary. And since I disabled search suggestions in the urlbar (but not for the searchbar), the new behaviour does not give me search suggestions.

I see three ways to solve my problem: either use the old behaviour (opening the "home page"), show search suggestions when Ctrl + K has been pressed, but not if Ctrl + L has been pressed or use the behaviour used in Google Chrome: "Ctrl + K" inserts a question-mark, which indicates the current text is a search.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1315328

Comment 2

10 months ago
I made a WebExtension that brings back this feature :) Enjoy!

https://addons.mozilla.org/en-US/firefox/addon/control-k-to-about-home/

There are 2 limitations: It only works in web pages so it will not work when you are in about:addons for examaple and the second limitation is that it does not work in some web sites for example in AMO it does not work.
You need to log in before you can comment on or make changes to this bug.