Regression Audio indicator appears when I enable sound in a tab that isn't producing sound.

UNCONFIRMED
Unassigned

Status

()

Firefox
Tabbed Browser
UNCONFIRMED
9 months ago
3 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
I have a problem with Firefox Beta 52. It doesn't happen in Firefox ESR 45.
Sometimes when I enable sound in tab without sound, it displays audio indicator.
It happens unpredictably, however, I noticed one specific scenario when it happens

1. Open http://youtube.com/watch?v=ZGqhhx8cxMg
2. Disable sound in tab, then stop the video, then enable sound in tab

Result: Audio indicator appears
Expected: No sound indicator

Comment 1

9 months ago
I guess this is due to bug 1232357, you have to wait a few seconds before it will hide.
Has STR: --- → yes
Component: Untriaged → Tabbed Browser

Comment 2

9 months ago
yes, it's by design, there is a fading time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
(Reporter)

Comment 3

9 months ago
(In reply to Loic from comment #2)
> yes, it's by design, there is a fading time.

My bug is not about fading time. It's about audio indicator shown in tab that never produced sound

So design is: when user disables "mute" function in a tab, to show audio indicator to demonstrate that the tab was producing sound (when in fact it wasn't)? Pls confirm.
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 4

9 months ago
Google Chrome doesn't do this.

Comment 5

9 months ago
Try the "2. Disable sound in tab, then stop the video, *then waiting for at least 5 seconds*, then enable sound in tab", the issue still exists?
Flags: needinfo?(684sigma)

Comment 6

9 months ago
There is a delay.
If you quickly mute the tab, pause the video and demute the tab, the sound icon stays briefly visible (the delay is here) then disappears because the video has been paused (i.e. no sound).
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 7

9 months ago
First of all, I went back, because the same bug happens in Chrome, so comment 4 is wrong.

> Try the "2. Disable sound in tab, then stop the video, *then waiting for at
> least 5 seconds*, then enable sound in tab", the issue still exists?

This is not what I did. The issue still exists.


(In reply to Loic from comment #6)
> There is a delay.
> If you quickly mute the tab, pause the video and demute the tab, the sound
> icon stays briefly visible (the delay is here) then disappears because the
> video has been paused (i.e. no sound).

- I did not do anything "quickly". I several times disabled "mute" feature in tab, and it showed me audio indicator, while no sound was present. I simply provided a reliable scenario for you to reproduce.
- The sound icon is visible for a long time, this is all that matters. Several times I disabled "mute" feature in tab, saw audio indicator, thought that video stream is still playing, just that exact part of the video produces very silent sound, so I scrolled tab strip away to work with other tabs, expecting some more sound to come from the tab. I haven't seen that the icon disappears, otherwise I would enable music in another tab.

My bug is not about any delay. When I disable "mute" feature in tab, it gives me the information "there's sound in this tab". I didn't want to get any irrelevant information, and asked the confirmation, whether current design involves giving the user the false information. I'm asking you the 2nd time, please confirm that or reopen the bug
(I can do it myself, but I'm not doing it, because there seems to be some misunderstanding)
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Updated

9 months ago
Flags: needinfo?(684sigma)

Updated

9 months ago
Blocks: 1188860
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

9 months ago
As I said, I can't reproduce it. NI flag cleared.
Flags: needinfo?(epinal99-bugzilla2)
You need to log in before you can comment on or make changes to this bug.