bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Surface drawn ~2x size of window on HiDPI Wayland

RESOLVED FIXED

Status

()

Core
Graphics
P3
normal
RESOLVED FIXED
a year ago
6 months ago

People

(Reporter: kevincox, Assigned: stransky)

Tracking

(Blocks: 1 bug, {dpi})

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8845181 [details]
Screenshot from 2017-03-08 23-33-02.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170307144106

Steps to reproduce:

Using firefox from this commit: https://github.com/stransky/gecko-dev/commit/baee29e5059080bbc0e55d1a77e753f42922b548

GDK_BACKEND=wayland firefox

Also tried with GDK_DPI_SCALE=0.5


Actual results:

The display was drawn ~2x the size of the window. Input and the window decorations were the expected size.


Expected results:

The display was drawn to match the window.

Updated

a year ago
Component: Untriaged → Graphics
Keywords: dpi
Product: Firefox → Core
(Reporter)

Comment 1

a year ago
Created attachment 8845183 [details]
layout.css.devPixelsPerPx = 1
(Reporter)

Comment 2

a year ago
Created attachment 8845184 [details]
layout.css.devPixelsPerPx = -1
(Reporter)

Comment 3

a year ago
I couldn't find anything similar to this, let me know if you want any more information or to try any other versions.
(Reporter)

Comment 4

a year ago
cc stransky@redhat.com in case you are interested.
Whiteboard: [gfx-noted]
Blocks: 635134

Comment 5

a year ago
I can confirm this issue.
I am running org.mozilla.FirefoxNightlyWayland 55.0a1 (2017-06-02) flatpak from https://firefox-flatpak.mojefedora.cz/
Assignee: nobody → stransky
The issue is a missing call to wl_surface_set_buffer_scale(2) when Firefox starts displaying the 2× buffer in the chrome+content surface, see bug 1228424 comment 5.
That's already fixed by latest trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.