Closed Bug 1345703 Opened 5 years ago Closed 5 years ago

[meta] Byte stream-specialized tokenizer

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1351107
Performance P3

People

(Reporter: shu, Assigned: Waldo)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

A tokenizer specialized for Latin1 should be a healthy speed up for Latin1 scripts.
Depends on: 1344152
Summary: [meta] Latin1-specialized tokenizer → [meta] Byte stream-specialized tokenizer
See comments in bug 1344152. UTF-8 seems to be the better approach. Being able to parse byte streams directly without inflating is likely the the important thing, regardless of approach.
Depends on: 1347711
Blocks: FBFeed
Whiteboard: [qf]
Marking p1 because parsing improvements directly lead to load time improvements.  Inflation is both linear on the source, and also the output is twice the size, causing lots of memory/cache churn.
Whiteboard: [qf] → [qf:p1]
Depends on: 1351107
Whiteboard: [qf:p1] → [qf:p2]
Keywords: perf
Jeff can you evaluate if this work still makes sense?
Assignee: nobody → jwalden+bmo
Flags: needinfo?(jwalden+bmo)
Whiteboard: [qf:p2] → [qf:p1]
Whiteboard: [qf:p1] → [qf:p3]
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jwalden+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1351107
Performance: --- → P3
Whiteboard: [qf:p3]
You need to log in before you can comment on or make changes to this bug.