Can't seek to last audio frame on OS X treeherder

VERIFIED FIXED in Firefox 53

Status

()

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

unspecified
mozilla55
Points:
---

Firefox Tracking Flags

(firefox53 verified, firefox54 verified, firefox55 verified)

Details

Attachments

(4 attachments)

(Assignee)

Description

2 years ago
Noticed the problem after seeing timeout in a newly test added..

Like here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a6594540ac0bb196744ce6869535282a37f622cc

From the logs, it appears that on the 10.10 treeherder test, we can't seek to the last two audio frames, the decoder returns nothing, only after the 3rd frame input will the decoder return something...

I can't reproduce it locally, and what's even weirder is that it appears to work on debug build for some reasons...
(Assignee)

Updated

2 years ago
Blocks: 1342913
No longer blocks: 1341913
(Assignee)

Updated

2 years ago
See Also: → bug 1321249
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 5

2 years ago
mozreview-review
Comment on attachment 8845320 [details]
Bug 1345756: P1. Add mochitest.

https://reviewboard.mozilla.org/r/118502/#review120432
Attachment #8845320 - Flags: review?(gsquelart) → review+

Comment 6

2 years ago
mozreview-review
Comment on attachment 8845321 [details]
Bug 1345756: P2. Fix coding style.

https://reviewboard.mozilla.org/r/118504/#review120436
Attachment #8845321 - Flags: review?(gsquelart) → review+

Comment 7

2 years ago
mozreview-review
Comment on attachment 8845322 [details]
Bug 1345756: P3. Fix coding style.

https://reviewboard.mozilla.org/r/118506/#review120438
Attachment #8845322 - Flags: review?(gsquelart) → review+

Comment 8

2 years ago
mozreview-review
Comment on attachment 8845323 [details]
Bug 1345756: [MSE] P4. Pre-roll AAC by 2112 audio frames.

https://reviewboard.mozilla.org/r/118508/#review120440
Attachment #8845323 - Flags: review?(gsquelart) → review+

Comment 9

2 years ago
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 5b5b32b145a9 -d 7368729b7ba0: rebasing 381160:5b5b32b145a9 "Bug 1345756: P1. Add mochitest. r=gerald"
merging dom/media/mediasource/test/mochitest.ini
rebasing 381161:7e168336ad94 "Bug 1345756: P2. Fix coding style. r=gerald"
rebasing 381162:a2000a89f9e4 "Bug 1345756: P3. Fix coding style. r=gerald"
merging dom/media/mediasource/MediaSourceDemuxer.cpp
warning: conflicts while merging dom/media/mediasource/MediaSourceDemuxer.cpp! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 21

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/574f66f6a635
https://hg.mozilla.org/mozilla-central/rev/9b53eaf9969d
https://hg.mozilla.org/mozilla-central/rev/abc38feea690
https://hg.mozilla.org/mozilla-central/rev/e39dc94fc219
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Updated

2 years ago
Flags: needinfo?(jyavenard)
(Assignee)

Comment 22

2 years ago
Comment on attachment 8845323 [details]
Bug 1345756: [MSE] P4. Pre-roll AAC by 2112 audio frames.

Approval Request Comment
[Feature/Bug causing the regression]: Been like that for a while
[User impact if declined]: Some Seeks would never complete (including on Youtube). Also this is required for the uplift performed in bug 1342913 to succeed.
[Is this code covered by automated tests?]: yes, new tests were written too.
[Has the fix been verified in Nightly?]: Yes, new mochitests ensure it's working
[Needs manual test from QE? If yes, steps to reproduce]: Can do, https://people-mozilla.org/~jyavenard/tests/mse_mp4/1347101/t.html, if the fix is in, the text "ok(true) seek completed" will appear, otherwise it won't. Can be checked on mac os 10.10.1 (same version as treeherder)
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no. 
[Why is the change risky/not risky?]: We have the same approach with Opus already, just extending to AAC decoder.
[String changes made/needed]: None
Attachment #8845323 - Flags: approval-mozilla-beta?
Attachment #8845323 - Flags: approval-mozilla-aurora?

Updated

2 years ago
status-firefox53: --- → affected
status-firefox54: --- → affected
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: qe-verify+
Flags: needinfo?(brindusa.tot)
(Assignee)

Comment 24

2 years ago
A manual verification is going to be very difficult without access to the machine of treeherder.
That's what the mochitest does on treeherder.

If you revert P4, then the test added with P1 will now fail on the OS X runs.


As seen on this run:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c3929c97fb4863e98e9793de8d15e429d4e3a957

"TEST-UNEXPECTED-FAIL | dom/media/mediasource/test/test_SeekToLastFrame_mp4.html | Test timed out. "
Comment on attachment 8845323 [details]
Bug 1345756: [MSE] P4. Pre-roll AAC by 2112 audio frames.

Fix an video playback issue on OS X treeherder. Aurora54+ & Beta53+.
Attachment #8845323 - Flags: approval-mozilla-beta?
Attachment #8845323 - Flags: approval-mozilla-beta+
Attachment #8845323 - Flags: approval-mozilla-aurora?
Attachment #8845323 - Flags: approval-mozilla-aurora+
needs beta rebasing

grafting 407219:e5d344d97791 "Bug 1345756: [MSE] P4. Pre-roll AAC by 2112 audio frames. r=gerald a=gchang"
merging dom/media/mediasource/MediaSourceDemuxer.cpp
warning: conflicts while merging dom/media/mediasource/MediaSourceDemuxer.cpp! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(jyavenard)
I reproduced this issue on Nightly 55.0a1 from 03/12/2017, Build ID 20170312030213 on Mac OS X 10.10. I tested with video from https://people-mozilla.org/~jyavenard/tests/mse_mp4/1347101/t.html - video does not start playing and the text "ok(true) seek completed" does NOT appear.

I can confirm the fix on latest Nightly 55.0a1, Build ID 20170326030204 on Mac OS X 10.10. I tested with same video https://people-mozilla.org/~jyavenard/tests/mse_mp4/1347101/t.html - video start playing and the text "ok(true) seek completed" is displayed.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
Flags: needinfo?(brindusa.tot)
Managed to reproduce the issue on Firefox 53.0b7, under Mac OS X 10.11.
The issue is no longer reproducible on Firefox 53.0b8, or on Firefox 54.0a2 (2017-03-31).
Tests were performed under Mac OS X 10.10.4 and under Mac OS X 10.11.
status-firefox53: fixed → verified
status-firefox54: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.