Closed Bug 1345845 Opened 3 years ago Closed 2 years ago

Find out what to do with idle connections opened for urgent-start requests

Categories

(Core :: Networking: HTTP, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1405446
Tracking Status
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix

People

(Reporter: mayhemer, Assigned: xeonchen)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

We can go up to 10 connections per host when there is a bigger number of urgent-start requests in parallel.  The 4 connections beyond the regular 6 conns limit will be left open and when not active, held in the idle pool (if keep-alive) for reuse.  This could lead to excessive parallelism in some situations what might be unwanted.

Some more assessment is needed before we find out what exactly to do here, if anything.
Blocks: CDP
Summary: Find out what to do with connections open for urgent-start requests when idle → Find out what to do with idle connections opened for urgent-start requests
When they are reclaimed I would close them if the urgent q is empty, otherwise recycle them normally.
Whiteboard: [necko-active]
No owner...
Whiteboard: [necko-active] → [necko-backlog]
I think you need to resolve this as part of introducing urgent connections..
Assignee: nobody → honzab.moz
Whiteboard: [necko-backlog] → [necko-active]
Priority: -- → P3
Assignee: honzab.moz → nobody
This bug should have an owner. Maybe Gary?
Assignee: nobody → xeonchen
Note that this is not needed to fix for 57.  There is no obvious or known problem with this and urgent-start will open new connections rarely.
Priority: P3 → P4
Bulk priority update: https://bugzilla.mozilla.org/show_bug.cgi?id=1399258
Priority: P4 → P1
Priority: P1 → P3
Whiteboard: [necko-active]
Depends on: 1405446
Whiteboard: [necko-triaged]
bug 1405446 effectively fixes the stated issue.  urgent conns (including all excessive ones) are preferred only for urgent transactions.  hence, kept idle when no urgent transactions are coming and time out naturally.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405446
You need to log in before you can comment on or make changes to this bug.