http requests initiated by flash plugin are not shown in Network tab in Developer Tools

UNCONFIRMED
Unassigned

Status

P3
normal
UNCONFIRMED
2 years ago
2 months ago

People

(Reporter: teo8976, Unassigned)

Tracking

50 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

- Visit a page that contains some flash content (swf) which does http requests (e.g. uploads)
- Open Developer Tools -> Network
- have the flash content make some http requests


Actual results:

The requests made by the flash content are not listed


Expected results:

they should be, just like requests made by javascript code, and by any other plugin.
ALL requests should be listed.

This is outrageous. I have a swf that triggers an error only in Firefox (works perfectly fine in Chrome), and I can't **** debug it.

Comment 1

2 years ago
Can you provide the page for reproduce?
Component: Untriaged → Developer Tools: Netmonitor
(Reporter)

Comment 2

2 years ago
No I can't. The one I have is private.

However ANY page with an swf performing http requests will do.
Can somebody please provide a simple page that we can use to see the problem on our machines?
This is usually helping a lot and increasing the chance that the report will get fixed.

Thanks!
Honza
Priority: -- → P3

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.