Closed Bug 134601 Opened 18 years ago Closed 18 years ago

Component Manager and Main thread being held past XPCOM shutdown. 'cnt == 0'

Categories

(Core :: XPCOM, defect, major)

defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 78861

People

(Reporter: Henry.Jia, Assigned: dougt)

Details

(Keywords: memory-leak, perf, Whiteboard: see also 78861)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    0000000000

When mozilla closed, it shows that there is some references that are not
released. See the following.
###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0',
file nsXPComInit.cpp, line 582
###!!! Break: at file nsXPComInit.cpp, line 582
###!!! ASSERTION: Main thread being held past XPCOM shutdown.: 'cnt == 0', file
nsThread.cpp, line 438
###!!! Break: at file nsThread.cpp, line 438

Reproducible: Always
Steps to Reproduce:
1.Run mozilla
2.Close it, then you'll see the assertion.
3.

Actual Results:  Such assertion.

Expected Results:  No such assertion.
Keywords: mlk, perf
Whiteboard: see also 78861
dup.

*** This bug has been marked as a duplicate of 78861 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
fwiw you reported two bugs here, that's ill advised.

vrfy dupe
Status: RESOLVED → VERIFIED
Oh, sorry. Because the 'Main Thread' has the same issue now.
You need to log in before you can comment on or make changes to this bug.