If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in UIKit: [UICollectionView _endItemAnimationsWithInvalidationContext:tentativelyForReordering:animator:] + 1788

VERIFIED FIXED

Status

()

Firefox for iOS
General
P1
critical
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: csuciu, Assigned: farhan)

Tracking

({crash, regression, reproducible})

unspecified
Other
iOS
crash, regression, reproducible

Firefox Tracking Flags

(fxios7.0+, fxios-v7.0 verified, fxios-v8.0 verified)

Details

(Whiteboard: [MobileCore])

Attachments

(2 attachments)

(Reporter)

Description

7 months ago
Created attachment 8845815 [details]
Client  10-03-2017, 11-08.crash

Firefox beta 7.0 build 2011
iPad Air 2 (10.2)

1. Open a few tabs
2. In top tabs, tap on the first tab to select it
3. Rapidly hit Cmd + W a few times 

Result: Firefox crashes

This is a regression from https://github.com/mozilla-mobile/firefox-ios/commit/bf88f9faf693ee2d0e9a20244c8fc3253da31ebe
Reproduced on master with my Apple Bluetooth keyboard.
(Assignee)

Updated

7 months ago
Assignee: nobody → fpatel
Iteration: --- → 1.17
Priority: -- → P1
Whiteboard: [MobileCore]
(Assignee)

Comment 2

6 months ago
Created attachment 8846730 [details] [review]
Pull Request
Attachment #8846730 - Flags: review?(etoop)
(Assignee)

Comment 3

6 months ago
master https://github.com/mozilla-mobile/firefox-ios/commit/3dcec9f97c6bd929fbd009170915c25635e97116
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Whiteboard: [MobileCore] → [MobileCore][needsuplift]
(Reporter)

Comment 4

6 months ago
Verified as fixed on master d849b926d5c
status-fxios-v8.0: affected → verified
v7.x dd146129cab6a8c116917852ca0047980fc06fbe
status-fxios-v7.0: affected → fixed
tracking-fxios: ? → 7.0+
Whiteboard: [MobileCore][needsuplift] → [MobileCore]
(Reporter)

Comment 6

6 months ago
Unable to reproduce the crash on beta 2150.

Verifying as fixed.
Status: RESOLVED → VERIFIED
status-fxios-v7.0: fixed → verified
(Assignee)

Updated

6 months ago
Attachment #8846730 - Flags: review?(etoop)
You need to log in before you can comment on or make changes to this bug.