font accent shifts in redraw

RESOLVED DUPLICATE of bug 129400

Status

()

RESOLVED DUPLICATE of bug 129400
17 years ago
17 years ago

People

(Reporter: torgeir, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020326
BuildID:    2002032608

I have this problems for at least 3 months. I'm attaching two png's. Look at eg.
the mozilla2.png, in the line that starts with "BBC in November of 2001". The m
in November is distorted. 

This is causes by the text being rendered slightly differently offset depending
on wether the text is selected by dragging the mouse up or down. In this case
the text was selected by pointing to the word "financial" in the last line of
the paragraph, and then dragged up to the first line. Then I put another window
on top of mozilla and remove it, which caused a normal repaint.

More information on request. I'm running on madrake linux 8.2, and also saw this
on mandrake 8.1, on at least three different machines. It might be related to
Xfree86 (currently v4.2, also seen on v4.1).

Reproducible: Always
Steps to Reproduce:
1. select a range of text 
2. put a window over some of the selected text
3. remove window
(Reporter)

Comment 1

17 years ago
Created attachment 77032 [details]
picture shows selected text drawn with different accent on different lines (why?)
(Reporter)

Comment 2

17 years ago
Created attachment 77033 [details]
show text drawn with different accent depending on text being rendered by selection or redraw

I'm not shure this really relates to font accent, since I also see it on
images.
Ick, looks like one of those twips-to-pixel rounding error bugs.
(Reporter)

Comment 4

17 years ago
> Ick, looks like one of those twips-to-pixel rounding error bugs.

Yes, I see it all over mozilla. Do you have some reference to source code? I can
try building mozilla myself to catch the error.
(Reporter)

Comment 5

17 years ago
Created attachment 77048 [details]
strangely rendered text line

Look at the last text line of this shot.

Updated

17 years ago
Blocks: 134942

Comment 6

17 years ago
Changing QA contact
QA Contact: petersen → amar

Comment 7

17 years ago
Resolving as duplicate. If you feel this is not a duplicate, feel free to reopen.

*** This bug has been marked as a duplicate of 129400 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 134942
You need to log in before you can comment on or make changes to this bug.