Closed Bug 1346644 Opened 3 years ago Closed 3 years ago

Disable high priority vsync handling in parent process

Categories

(Core :: General, defect)

36 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla55
Tracking Status
firefox54 --- fixed
firefox55 --- verified

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(1 file)

No description provided.
Attachment #8846428 - Flags: review?(ehsan)
Comment on attachment 8846428 [details] [diff] [review]
parent_process_vsync_4_backout.diff

Approval Request Comment
[Feature/Bug causing the regression]: bug 1315570
[User impact if declined]:for example bug 1342849
[Is this code covered by automated tests?]: NA
[Has the fix been verified in Nightly?]: not yet, this is just a backout
[Needs manual test from QE? If yes, steps to reproduce]: see bug 1342849
[List of other uplifts needed for the feature/fix]: NA
[Is the change risky?]: backout, not risky
[Why is the change risky/not risky?]: see above
[String changes made/needed]: NA
Attachment #8846428 - Flags: approval-mozilla-aurora?
(I'll try to figure what is causing bug 1342849 and then re-enable high-prio also in parent process, but only in case we are in multiprocess setup, so not in current Fennec.)
Comment on attachment 8846428 [details] [diff] [review]
parent_process_vsync_4_backout.diff

Review of attachment 8846428 [details] [diff] [review]:
-----------------------------------------------------------------

We should probably make this be controllable by a pref the next time we re-enable...
Attachment #8846428 - Flags: review?(ehsan) → review+
Maybe. That might ease some testing.
But it would apply to parent process handling only, since making the pref working for child would be quite a bit harder.
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/950180909fd0
Disable high priority vsync handling in parent process, r=ehsan
https://hg.mozilla.org/mozilla-central/rev/950180909fd0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
Depends on: 1347545
Build ID: 20170314030215
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0

Verified as fixed on Firefox Nightly 55.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: needinfo?(brindusa.tot)
Comment on attachment 8846428 [details] [diff] [review]
parent_process_vsync_4_backout.diff

Backout bug 1315570. Aurora54+.
Attachment #8846428 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1352523
You need to log in before you can comment on or make changes to this bug.