RDM icon not working when Developer Tools in undocked (separate window)

VERIFIED FIXED in Firefox 55

Status

P1
normal
VERIFIED FIXED
2 years ago
2 months ago

People

(Reporter: viff3000, Assigned: jryans)

Tracking

({regression})

54 Branch
Firefox 55
regression
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170312084740

Steps to reproduce:

 - Open developer tools and click on 'Show in separate window' button.
 - Click on Responsive Design Mode button or use 'Ctrl-Shift-m' shortcut.

Running on Mint 18.1.



Actual results:

Nothing - unable to enter or exit RDM from the Developer Tools window.


Expected results:

Should have entered/exited RDM.

Comment 1

2 years ago
Old bug, so probably already filed. You have to focus on the tab before entering RDM with dev tools undocked.
Component: Untriaged → Developer Tools: Responsive Design Mode
Whiteboard: DUPEME
(Reporter)

Comment 2

2 years ago
Tab is focused. I can enter/exit RDM from the tab itself using the keyboard shortcut, but nothing works in the Dev Tools window.

Comment 3

2 years ago
You're right, it's a recent regression. :)

Reg range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=83e1a88a9833a498a0e841e37a822de99b0ed0c6&tochange=f6895ed1367c698cd60af71084f68950cdb2e630

Alexandre Poirot — Bug 1320149 - Prevent loading gcli when opening a toolbox. r=jwalker,miker
Blocks: 1320149
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → affected
status-firefox55: --- → affected
tracking-firefox54: --- → ?
tracking-firefox55: --- → ?
Ever confirmed: true
Flags: needinfo?(poirot.alex)
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Summary: RDM not working from Developer Tools in undocked, separate window → RDM icon not working when Developer Tools in undocked (separate window)
Whiteboard: DUPEME
(In reply to Tim Nguyen :ntim from comment #4)
> The browser console shows:
> 
> "browserWindow.gBrowser"

meant "browserWindow.gBrowser is undefined"
Tracking 54/55+ for this recent regression in Dev Tools.
tracking-firefox54: ? → +
tracking-firefox55: ? → +
(Assignee)

Updated

2 years ago
Assignee: nobody → jryans
Flags: needinfo?(poirot.alex)
Priority: -- → P1
Comment hidden (mozreview-request)
Probably worth a test so we avoid regressing this.

Comment 10

2 years ago
mozreview-review
Comment on attachment 8847683 [details]
Bug 1346647 - Fix RDM button for undocked toolbox.

https://reviewboard.mozilla.org/r/120598/#review123382

Nice catch.
I'm wondering other usage of this "toolbox.win.top" are also wrong?
Looks like this one could be as wrong:
http://searchfox.org/mozilla-central/source/devtools/client/framework/devtools-browser.js#754
Attachment #8847683 - Flags: review?(poirot.alex) → review+
(Assignee)

Comment 11

2 years ago
(In reply to Tim Nguyen :ntim from comment #9)
> Probably worth a test so we avoid regressing this.

Perhaps so!  I don't think I have time to write it right now, but I agree it would be good to have...
(Assignee)

Comment 12

2 years ago
mozreview-review-reply
Comment on attachment 8847683 [details]
Bug 1346647 - Fix RDM button for undocked toolbox.

https://reviewboard.mozilla.org/r/120598/#review123382

Looks like that's the only other usage of `toolbox.win.top`.  Since it landed at a different time and may or may not need uplifting, I filed bug 1348318 about this other usage.

Comment 13

2 years ago
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/576abf29e19c
Fix RDM button for undocked toolbox. r=ochameau
https://hg.mozilla.org/mozilla-central/rev/576abf29e19c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
(Assignee)

Comment 15

2 years ago
Comment on attachment 8847683 [details]
Bug 1346647 - Fix RDM button for undocked toolbox.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1320149 caused this when refactoring the DevTools toolbox buttons
[User impact if declined]: If declined, the button to toggle Responsive Design Mode won't work when the toolbox is undocked
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: DevTools only, only affects a single button
[String changes made/needed]: None
Attachment #8847683 - Flags: approval-mozilla-aurora?
Comment on attachment 8847683 [details]
Bug 1346647 - Fix RDM button for undocked toolbox.

Fix an RDM icon regression issue. Aurora54+.
Attachment #8847683 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 17

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/2f95244f6119
status-firefox54: affected → fixed
status-firefox-esr52: --- → unaffected

Comment 18

2 years ago
I have reproduced this bug with Firefox nightly 55.0a1 (2017-03-12) on Windows 10, 64 Bit.

The Bug's fix is now verified on latest nightly 55.0a1 (2017-03-22) and  latest developer edition  54.0a2 (2017-03-22) .

developer edition  54.0a2 :

Build ID  20170322004022
User Agent 	 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
   
nightly 55.0a1:

Build ID   	20170322030208
User Agent 	 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
   
[bugday-20170322]
Status: RESOLVED → VERIFIED
status-firefox54: fixed → verified
status-firefox55: fixed → verified

Updated

4 months ago
Product: Firefox → DevTools

Updated

2 months ago
status-firefox52: unaffected → ---
status-firefox53: unaffected → ---
status-firefox54: verified → ---
status-firefox55: verified → ---
tracking-firefox54: + → ---
tracking-firefox55: + → ---
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.