Closed Bug 1346735 Opened 3 years ago Closed 3 years ago

Clean-up unix_rand

Categories

(NSS :: Libraries, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: franziskus, Assigned: franziskus)

References

Details

Bug 889116 surfaced a couple issues in unix_rand.c. Let's fix them.
want to summarize the issues that need fixing? Is that only the things that are mentioned at the end of that other bug?
We can remove netstat calls in unix_rand. And I introduce a clean new entropy source for unix.
See the patch [1] for details.

[1] https://nss-review.dev.mozaws.net/D45
https://hg.mozilla.org/projects/nss/rev/eab257efdbf6b6d5ef4358e2bb197f9281ac2001
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1348798
Duplicate of this bug: 1257048
You need to log in before you can comment on or make changes to this bug.