Closed Bug 1346874 Opened 5 years ago Closed 5 years ago

Skip slower gray marking checks on Android

Categories

(Core :: JavaScript: GC, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: sfink, Assigned: sfink)

References

Details

Attachments

(2 files)

It's looking to me like the Android debug slowdown is a little excessive, so at least for now, I'd like to disable the additional checks on that platform and configuration only.
this is valid
I think that makes sense. There shouldn't be much Android-specific code that interacts with gray marking.
Blocks: 1292735
Blocks: 1305622
Blocks: 1345350
oops, I never posted the patch for review.
Attachment #8846755 - Flags: review?(continuation)
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Attachment #8846755 - Flags: review?(continuation) → review+
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/42720d7bd306
Skip gray mark check stack walk on DEBUG Android, r=mccr8
sfink - Thanks very much for your efforts here. +1 for the strategy of checking less on Android...but are you sure it is working? I was expecting a dramatic savings, but the Android Debug job times look about the same before/after your push on inbound, and some of the timeouts that started with the gray marking seem to be persisting (there have only been a few pushes since yours, so it's early and hard to say, but a few of the timeout failures have happened already). Maybe the ifdef is wrong somehow? Maybe most of the time for gray marking is going somewhere else??
There's also the "run the GC over and over again!" checks that might be taking lots of time.
https://hg.mozilla.org/mozilla-central/rev/42720d7bd306
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Needs more work.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
:sfink, sorry this fix didn't do the trick :(  Do you have another fix in the works that will land this week?  We are a couple weeks into some top intermittents and I would like to temporarily disable on Friday if we don't have something close to landing by then.
Flags: needinfo?(sphink)
Moar Android test disabling.
Attachment #8848277 - Flags: review?(continuation)
Attachment #8848277 - Flags: review?(continuation) → review+
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b47db00299f4
Disable slow gray mark checks on Android, r=mccr8
(In reply to Joel Maher ( :jmaher) from comment #9)
> :sfink, sorry this fix didn't do the trick :(  Do you have another fix in
> the works that will land this week?  We are a couple weeks into some top
> intermittents and I would like to temporarily disable on Friday if we don't
> have something close to landing by then.

Yeah, I'm throwing in the towel and disabling bug 1335751 entirely on Android.
Flags: needinfo?(sphink)
First few Android test results on inbound are looking good now. Thanks Steve.
https://hg.mozilla.org/mozilla-central/rev/b47db00299f4
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1347786
You need to log in before you can comment on or make changes to this bug.