Inconsistent synced tabs on Android

RESOLVED DUPLICATE of bug 1265314

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 1265314
9 months ago
2 months ago

People

(Reporter: eoger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
There are multiple problems with tab syncing on Android:
- It seems like we don't sync tabs that are from pinned top sites. (maybe intended)
- If no tab is open, we don't sync an empty list (which means on desktop the last open tab will appear this device..)

Comment 1

9 months ago
The pinned tab claim is strange, as the two shouldn't be connected in any way. Pins in Fennec are implemented as bookmarks which belong to a special folder. iirc, opening a tab from a pin isn't any different than opening a tab in any other way. What are you seeing specifically?

As I'm testing this now, _none_ of my tabs are actually syncing :/

Comment 2

9 months ago
It seems that there's some "prior art" here.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1265314

Comment 3

9 months ago
Let's file and investigate any "pinned tab" issues separately, as the two are unlikely to be related.

Updated

2 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.