regchrome and regxpcom should warn if LD_LIBRARY_PATH is not set

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: bulbul, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When i try to run regxpcom, i get the following error at the console:

[root@guido mozilla]# ./regxpcom
./regxpcom: error while loading shared libraries: 
   libxpcom.so: cannot load shared object file: No such file or directory

Am am running this as root and i also tried explicitly adding the mozilla
directory to PATH and then doing "export PATH".

Using Mozilla Linux trunk build 2002-04-01-08 on RedHat 7.1.
(Reporter)

Comment 1

17 years ago
I forgot to mention that linxpcom.so is present in the directory.
(Reporter)

Comment 2

17 years ago
On another machine, running RedHat 7.2, i get this error doing the same thing:

[root@dhcppc1 mozilla]# ./regxpcom
./regxpcom: error while loading shared libraries: 
   ./regxpcom: undefined symbol: NS_InitXPCOM2

Comment 3

17 years ago
LD_LIBRARY_PATH=. ./regxpcom should solve this problem
(Reporter)

Comment 4

17 years ago
You are correct. However, i think that regxpcom should put out a warning instead
of just failing if LD_LIBRARY_PATH is not set. This should be true of regchrome
instead. I know that this is not a big end-user issue, but it would certainly
avoid some frustration on the part of people debugging certain things. I ran
into this one trying to do QA work on Calendar. 

I'm changing severity to "enhancement" and changing the summary to "regchrome
and regxpcom should warn if LD_LIBRARY_PATH is not set".
Severity: critical → enhancement
Summary: cannot run regxpcom, does not find libxpcom.so → regchrome and regxpcom should warn if LD_LIBRARY_PATH is not set

Comment 5

17 years ago
There's not much regxpcom can do. It's dynamically linked against libxpcom.so so
before it ever runs, the system does not find libxpcom.so and bails out.

Unless regxpcom is changed to use dlopen or something or regxpcom is replaced
with a wrapper that sets library path and calls the actual regxpcom, nothing
will happen.
(Reporter)

Comment 6

17 years ago
If that's the case, this should probably be marked "won't fix", so this is what
i'm doing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: doug.turner → xpcom
You need to log in before you can comment on or make changes to this bug.