Mozilla Firefox Nightly 55.0a1 (2017-03-14) crashes on wishtv.com in [@ gl::Compiler::release ]

VERIFIED FIXED in Firefox 55

Status

()

--
critical
VERIFIED FIXED
2 years ago
5 months ago

People

(Reporter: Virtual, Assigned: cyu)

Tracking

({crash, nightly-community, regression})

55 Branch
mozilla55
x86
Windows 10
crash, nightly-community, regression
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ verified)

Details

(Whiteboard: [fixed by updated patch from bug #1320134], crash signature, URL)

Summary: Mozilla Firefox Nightly crashes on wishtv.com → Mozilla Firefox Nightly 55.0a1 (2017-03-14) crashes on wishtv.com
[Tracking Requested - why for this release]: Regression
Crash Signature: [@ libglesv2.dll@0x8f21d ] → [@ libglesv2.dll@0x8f21d ] [@ gl::Compiler::release ]
tracking-firefox55: --- → ?
Summary: Mozilla Firefox Nightly 55.0a1 (2017-03-14) crashes on wishtv.com → Mozilla Firefox Nightly 55.0a1 (2017-03-14) crashes on wishtv.com in [@ gl::Compiler::release ]
This crashlog signature doesn't look like A/V playback issue,
it looks more like Canvas WebGL,
so in the end it could be that it wasn't caused by:
fa8ab4dc0e42	Bas Schouten — Bug 1346258: Fix disabling of sync texture usage. r=mattwoodrow

@ Jim Jeffery - Can you run mozregression to specify which bug is the cause between builds from comment 30? Thank you very much in advance
Component: Audio/Video: Playback → Canvas: WebGL
Flags: needinfo?(jmjeffery)
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #3)
> This crashlog signature doesn't look like A/V playback issue,
> it looks more like Canvas WebGL,
> so in the end it could be that it wasn't caused by:
> fa8ab4dc0e42	Bas Schouten — Bug 1346258: Fix disabling of sync texture
> usage. r=mattwoodrow
> 
> @ Jim Jeffery - Can you run mozregression to specify which bug is the cause
> between builds from comment 30? Thank you very much in advance

I can't get Mozregress to run - it keeps kicking out a json error about no pushlog found when I try to run it using the 'good' & 'bad' cset range.
Flags: needinfo?(jmjeffery)
OK got it to run on date range, Mozregress is pointing to:

Bug 1346005: add audio samples-inserted logging using AudioLatency:4 r=padenot
Thank you very much! This will speed up fixing this bug.
Blocks: 1346005
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(bas) → needinfo?(rjesup)
Tracking 55+ for this crash regression.
tracking-firefox55: ? → +
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #5)
> OK got it to run on date range, Mozregress is pointing to:
> 
> Bug 1346005: add audio samples-inserted logging using AudioLatency:4
> r=padenot

That would be really odd.... given the stack is in GL, and the patch in question adds logging to WebRTC audio
Flags: needinfo?(rjesup)
I just ran Mozregress again under a new profile, no changes and still get the same patch as the culprit in the regression range.

So I do not know from here how else I can help resolve this...

Comment 10

2 years ago
Have some more pages which are crashing with this signature. crash-stats.mozilla.com is also a candidate...
So let's block both bugs ;)
Blocks: 1320134
Flags: needinfo?(cyu)
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
(Assignee)

Comment 13

a year ago
My bad. I can confirm that 1320134 caused this crash.
Flags: needinfo?(cyu)
The back-out of bug 1320134  has fixed the crashes at reported in comment #0

Can this be closed or is there still a 'fix' coming ?

Thanks for the quick response.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #14)
> The back-out of bug 1320134  has fixed the crashes at reported in comment #0
> 
> Can this be closed or is there still a 'fix' coming ?
> 
> Thanks for the quick response.

See bug #1320134 comment #60
(Assignee)

Comment 16

a year ago
The patches in bug 1320134 uses wrong calling convention in calling trampoline of the wrapped TlsFree() call. GL compiler frees TLS slots in cycle collection. The bug is reproduced and fixed locally, and I'll make sure this doesn't happen when I reland 1320134. So I think we can close this bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Latest build with these crashlog reports signatures was Mozilla Firefox Nightly 55.0a1 (2017-03-15), so I'm marking this bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
status-firefox55: affected → verified
Whiteboard: [fixed by updated patch from bug #1320134]
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.