Enable linux64-ccov coverage collection for common tests set

RESOLVED FIXED in Firefox 55

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: madeleinechercover, Assigned: madeleinechercover)

Tracking

(Blocks 1 bug)

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/602.4.8 (KHTML, like Gecko) Version/10.0.3 Safari/602.4.8
Depends on: 1347244
Depends on: 1347245
Comment on attachment 8847276 [details]
Bug 1347241 - Enable linux64-ccov coverage collection for common tests set;

https://reviewboard.mozilla.org/r/120302/#review122204

hey, one nit here, I would be happy to review again if you want to do the transform thing :)

::: devtools/client/memory/test/browser/browser.ini:18
(Diff revision 1)
>      skip-if = debug # bug 1219554
>  [browser_memory_displays_01.js]
>  [browser_memory_clear_snapshots.js]
>  [browser_memory_diff_01.js]
>  [browser_memory_dominator_trees_01.js]
> +    skip-if = coverage # bug 1347244

please do not indent here- I see there is prior art in this file to give you a bad example :(

::: taskcluster/ci/test/tests.yml:474
(Diff revision 1)
>      description: "Mochitest a11y run"
>      suite: mochitest/a11y
>      treeherder-symbol: tc-M(a11y)
> +    instance-size:
> +        by-test-platform:
> +            linux64-ccov/opt: xlarge

I wonder if we should use a transform for instance sizes and linux64-ccov- not to be solved in this bug, but worth considering for a follow up bug :)
Attachment #8847276 - Flags: review?(jmaher) → review+
Comment on attachment 8847276 [details]
Bug 1347241 - Enable linux64-ccov coverage collection for common tests set;

https://reviewboard.mozilla.org/r/120302/#review122228

Great work on this!

Everything looks good to me, the only things that need to be taken care of are what Joel pointed out. Also, if you add to the transform, I think we should also set the e10s flag in the transform since most code-coverage tests disable it.
Attachment #8847276 - Flags: review?(gmierz2) → review+
Great, I'll be submitting a follow-up bug for the transform soon!
Assignee: nobody → madeleinechercover
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dd772ad610d1
Enable linux64-ccov coverage collection for common tests set; r=gmierz,jmaher
https://hg.mozilla.org/mozilla-central/rev/dd772ad610d1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Madeliene,

I see a full set of tests on one of your recent try pushes:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3fb43f3b51ec24e235e3b52b99653275da08c089

but a nightly build from ~20 hours ago doesn't have all the new tests:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=3945f2297b997d59662bdb8ac20e092363eea532&filter-searchStr=ccov

can you confirm that what was pushed is the proper set of changes:
https://hg.mozilla.org/mozilla-central/rev/dd772ad610d1
Flags: needinfo?(madeleinechercover)
Yes, that's the proper set of changes. I've just done another build to be sure, and the branch with the change set (https://hg.mozilla.org/mozilla-central/rev/dd772ad610d1) does run all the tests.
Flags: needinfo?(madeleinechercover)
it appears we needed to wait an extra day, the merge needed to happen and the results from this past weekend have the full set of tests running.
You need to log in before you can comment on or make changes to this bug.