New for FF v 52.0 - Restart fails to load pages at focus tabs

UNCONFIRMED
Unassigned

Status

()

Firefox
Session Restore
UNCONFIRMED
a year ago
11 months ago

People

(Reporter: reibjerk, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

I updated FF from ver 51.0.1 to ver 52.0. I run 32-bit on Win7 64-bit since Java (32 or 64) does not work on 64-bit FF.
When I started FF after the update I get a result that I have not seen before on any previous version of FF.



Actual results:

When Firefox starts: Show my windows and tabs from last time. Is the setting I'm using.
When this (v 52.0) FF started the focus-tabs in most of my windows would not load. The focus tabs are the tabs that are actually live linked to the
actual web-site, as opposed to the 'neighbor' tabs that are inactive until actually needed/invoked.
The tabs would work and work for hours displaying no error and just a blank page.
I would have to stop/abort ('X') the connection and manually retry in order for the page to load properly.



Expected results:

The web page(s) (the single focus tab in each FF window) should have loaded as normal.
This is so serious that I will now reinstall ver 51 of FF (32-bit, since 64-bit does not work with Java..)
I've now re-installed version 51.0.1 of FF and everything worked as before. All the failing pages with 52.0
are now loading OK.
(Reporter)

Comment 1

a year ago
The most noteworthy, and possibly important change to my system is that I'm using a modified hosts -file that blocks access to a lot of ads/spam.
Here's a part of the file, showing what kind of entries that is in the file;

# This MVPS HOSTS file is a free download from:            #
# http://winhelp2002.mvps.org/hosts.htm                    #
#                                                          #..
0.0.0.0 fr.a2dfp.net
0.0.0.0 m.fr.a2dfp.net
0.0.0.0 mfr.a2dfp.net
0.0.0.0 ad.a8.net
...
==> This is already causing trouble with storing web pages locally (Bug 1007251 ), so
if there are changes to FF 52.0 with regards to handling ad -sites/-servers this could be the culprit...

Just a suggestion.
(Reporter)

Comment 3

11 months ago
Fresh Profile: No. This would defeat the purpose of defining a bug - if a new version cannot handle running/updating without requiring a new profile to be created it would be next to useless.

w10s: Multiprocess Windows 	0/14 (Disabled by add-ons)
Any easy way to see what add-on that is disabling this?
Flags: needinfo?(reibjerk)
(Reporter)

Comment 4

11 months ago
With regard to the "Disabled by add-ons" above; I tried starting with all add-ons disabled (safe mode), but it still says disabled by add-ons..? Does this mean that it is not enough yo disable all add-ons - they would have to be uninstalled all of them ?

Multiprocess Windows 	0/14 (Disabled by add-ons)
Safe Mode 	true

Comment 5

11 months ago
Non-e10s should not cause this problem.

Can you use a clean profile to identify this problem caused by the current profile?
Flags: needinfo?(reibjerk)
(Reporter)

Comment 6

11 months ago
I'll try. But I'll have to set aside some time for this. If I'm the only one having this problem then it could be something which is not a bug (affecting many) in the code and perhaps some corruption in the profile. (Which of course could have to be because of another type of bug with the piece of code that made the profile.)
(Reporter)

Comment 7

11 months ago
I have now rerun with a newly created profile. First with 51.0.1 - all OK as before. Then I upgraded to 52.0 and ran, now WITHOUT the problems initially reported. I also updated to 52.0.1 without it making any difference. It is now working with the newly created profile. The only thing left is to make _some_ more configuring, including installing _some_ (not many - just a few) plugins. Even so, I'll add them one by one because I'd like to know which one blocked Multiprocess Windows (e10s as you called it - strange name when I do not know the story behind it..).
If the opposite of e10s=true is serially running multiple windows, then this would have to be considered a major issue, so this is something I'd like to avoid...!? (Wouldn't Windows make multitasking between main windows at 'yield'-points/-system calls...? - hence admitting blatantly that I do not know the true effect of e10s=false..)

I may get back with an additional comment after doing the above, if anything is affected by doing so.

I wonder; since creating a new profile made this problem go away, will the conclusion be that this just adds to all the 'rarities' that Firefox is troubled with and one has to accept that FF eventually will corrupt itself and forcing a 'totally clean' install is just one of many tasks one is forced to accept in order to make FF run?

There really are quite a number of troubles with FF that I'm forced to deal with in order to be able to use FF at all! I've mentioned earlier that I cannot run the 64-bit version of FF since neither 32-bit nor 64-bit Java works with this FF. So I run 32-bit FF. Also, quite serious, is the fact that after FF have 'been sitting' some hours (FF have been running for a number of hours - not days), I need to stop and re-start FF to prevent it from moving into a slow-motion mode where I constantly get (Not Responding) and nothing can be done. So, before it gets that bad I select (Up Right) 'Open Menu' and 'Exit Firefox' so that all windows in FF are closed. then I go to Task Mgr and wait until Firefox task have disappeared before starting it again. (I'm using the setting 'When Firefox starts': 'Show my windows and tabs from last time'.) Now it can be used some more hours... (Fairly modern/fast machine. 16GB Mem (DDR3, 1600), CPU Intel Core i7-4770S - LGA1150 Socket - 3.1 (3.9) GHz..)
Flags: needinfo?(reibjerk) → needinfo?(yfdyh000)
(Reporter)

Comment 8

11 months ago
One thing I forgot to ask about. I know it's easy to ask and not necessary as easy to answer, but here it goes;
There is now an indication that there might have been some sort of data corruption/inconsistency with my older profile. After creating a new profile the problem went away.
A person with a good grip on what the changes are from version 51.0.1 to 52.0, could perhaps know/find out/.. what it was that made FF version 52.0 go hiccup, whereas the slightly older version 51.0.1 had no such problem.
What is different in version 52 code that made it react on the older profile, where the code in version 51 did not stumble on this data at all !?

Those of you - or perhaps only one person that have made changes to the code that could react on some error with the older profile - should be identified ! I do not know how many have been involved in coding from 51.0.1 to 52.0 - but I guess that some of You lot that _are_ involved with current coding and compiling could have such overview...
(Reporter)

Comment 9

11 months ago
Why do I get the distinct feeling that Firefox is moving more backwards than forwards ??
Does this browser add more and more limitations as opposed to being less and less bug-ridden ?

Perhaps you (the go-happy coders) should set a lock on adding new 'features' (whatever they are) and focus on removing bugs from the code.

Here is something that really made me feel I'm moving backwards with a higher version number for FF;
"
Starting with Firefox Version 52 (released in March 2017), Firefox has limited support for plug-ins, and therefore will not run Java."

What is happening? Next could move limited support to no support for plugins? Then no graphics support?
This sounds extreme, I know but what is actually happening? What would be the benefit of minimizing FF market share further? FF vs Chrome market shares; January each year (https://www.w3schools.com/Browsers/default.asp )
      % FF vs Chrome
2010: 46% 10%
2011: 42% 23%
2012: 37% 35%
2013: 30% 48%
2014: 26% 55%
2015: 23% 61%
2016: 18% 68%
2017: 15% 73% - I am truly sorry for this ranting, but I would not have 'bothered' if I would not hate the thought of having to leave FF for some other browser... But the issue is - I currently 'live with' a number of annoyances (like having to restart FF every couple of hours etc.) - but when I get the feeling (or fright?) that things may get even worse, then I have to foresee that I might be forced to do something that I hoped I would not have to.
I really, really hope I'm mistaken about 'reading the signs' as they seem to me now.
But I'd rather state my mind than just leave silently the Mozilla community, although I assume some would prefer the opposite...

Comment 10

11 months ago
If you cannot give the cause and/or the steps for reproduce, I can't understand the problem and to identify it (like mozregression). Problems caused by add-ons compatibility (e10s turn on, release versions, add-ons versions, settings) are common, so you needs to reproduce it using a clean profile and reliable steps.

If you think the problem may because an data corruption, you may have to provide the profile data (needs eliminate the privacy data) and steps, then hope it can be reproduced by others.

https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines#Other_details_you_should_heed


For other responses, as a volunteer, I cannot give answers.
Component: Untriaged → Session Restore
Flags: needinfo?(yfdyh000)
You need to log in before you can comment on or make changes to this bug.