Closed Bug 1347654 Opened 4 years ago Closed 3 years ago

mochitest-browser-chrome jobs "leak" if run multiple times in automation

Categories

(Testing :: Mochitest, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1391694

People

(Reporter: wlach, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

In testing bug 1343327, it seems like running mochitest-browser-chrome tests repeatedly (i.e. using the `repeat` or `run until fail` options) causes reports of "leaks" in the harness. Examples:

e10s browser_ext_tabs_reload_bypass_cache.js

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f9f1ae807d384f42912547621443e46db90b00f7&group_state=expanded&selectedJob=83857318

e10s browser_async_remove_tab.js:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f9f1ae807d384f42912547621443e46db90b00f7&group_state=expanded&selectedJob=83758884

I have confirmed that just running them once does not exhibit this behaviour. Also plain mochitests run just fine (have not tried other variants yet).

Ted, sorry to bug you, but I'm not sure who to ask: have you seen anything like this before? Any ideas on what might be happening? If you're not sure, feel free to just cancel the NI and I'll try to investigate further myself.
Flags: needinfo?(ted)
Blocks: 1322433
No longer blocks: 1343327
This isn't something I've seen before, sorry. The only thing I could think is that maybe the repeat option doesn't properly clean up the test the same way a normal run does?
Flags: needinfo?(ted)
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #1)
> This isn't something I've seen before, sorry. The only thing I could think
> is that maybe the repeat option doesn't properly clean up the test the same
> way a normal run does?

Yeah, I suspected the same when I first saw this, though I couldn't find any smoking guns when I looked at the code. Hopefully someone will be able to figure this out eventually...
See Also: → 1391694
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1391694
Duplicate of bug: 1391694
You need to log in before you can comment on or make changes to this bug.