Preferences not picked up from user.js file

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 83376
18 years ago
17 years ago

People

(Reporter: arpit, Assigned: bnesse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

18 years ago
I am running Mozilla build ID: 2002040108 on Linux Mandrake 8.1.

My preferences from user.js are not picked up. This used to work fine until
Mozilla 0.9.9.

I am able to reproduce this problem as many times as I run the browser.

Comment 1

18 years ago
if there is a problem with you user.js file, it could behave like you're seeing.

could you try with a new profile? if that works, then there is probably
something in your prefs.js file that is invalid.  try deleting stuff (back it up
first) and see if you can get it working again.
Reporter

Comment 2

18 years ago
I created a new profile as suggested and copied only my old user.js file. The
prefs.js file was new (default). On startup, mozilla complained:


INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory


And it wouldn't continue loading.

One setting in my user.js file was:
user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.5;
Windows NT 5.0)");

I changed that to:
user_pref("general.useragent.override", "Mozilla/5.0 (compatible; MSIE 5.5;
Windows NT 5.0)")

Now mozilla loaded normally. Additionally, the preferences listed in user.js
were all picked up. I could reproduce the above error message by switching the
user-agent string to its old value.

So as of now, the problem I reported originally in bug #134779 is solved.


Now for some gory details that may or may not be relevant but I will mention
anyway for completeness. This explains the sequence of steps I took when
upgrading from mozilla 0.9.9 to mozilla Build ID 2002040108:

- Delete all files in /usr/local/mozilla/
- Replace them with new files (build ID 2002040108)
- Run /usr/local/mozilla/mozilla
- Mozilla complains with following error message and fails to load:

INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory

- Not really knowing what I am doing, I delete the file   ~/.mozilla/version.
Unfortunately I am not sure of the name of this file that I deleted, but I think
that's what it was called.
- mozilla starts up without above error message, but asks me to convert my
netscape 4 profile to a mozilla profile (I had a netscape 4 profile under
~/.netscape too). I let it convert the profile.
- At this point I realize my user prefs are not being picked up even though the
file exists. I can reproduce the problem. I filed bug #134779.

By the way, after this whole fiasco, I don't have that file ~/.mozilla/version
created now. But things seem to be working fine.

Comment 3

18 years ago
From the new description of the problem, marking as a duplicate of bug 83376.

REPORTER: If you disagree, please feel free to REOPEN this bug. Thanks for using
mozilla

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.