Uplift three crash fixes to beta and/or aurora

RESOLVED FIXED

Status

()

defect
P1
normal
Rank:
12
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: padenot, Assigned: padenot)

Tracking

53 Branch
All
Windows
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox52 wontfix, firefox-esr52 fixed, firefox53 fixed, firefox54 fixed, firefox55 unaffected)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Attached is a beta patch for those bugs:
- Bug 1342389
- Bug 1345147
- Bug 1347453
Per IRC discussion, we may want to consider doing some backports to esr52 as well, but the situation for including them as an Fx52 dot release ride-along is more murky.
This is simply cherry picked from recent patches.
Attachment #8848109 - Flags: review?(kinetik)
Assignee: nobody → padenot
Status: NEW → ASSIGNED
Blocks: 1347453
Blocks: 1345147
Blocks: 1342389
Blocks: 1343972
Attachment #8848109 - Flags: review?(kinetik) → review+
This is the patch to land for beta.

MozReview-Commit-ID: LdcXcbTFxqL
This is the patch rebased for aurora.
Comment on attachment 8848534 [details] [diff] [review]
Uplift three crash fixes to beta

Approval Request Comment
[Feature/Bug causing the regression]: fallout from bug 1314514 where we made a crash less worrisome and reduced its volume
[User impact if declined]: low volume crashes
[Is this code covered by automated tests?]: no, we don't even know how this happens in the first place. One of the crash has a test upstream that we have disabled here because it takes too long, but we'll fix that soon (https://github.com/kinetiknz/cubeb/blob/master/test/test_overload_callback.cpp)
[Has the fix been verified in Nightly?]: yes, it's been landed for some time now
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: this is specifically prepared so that it can land on its own
[Is the change risky?]: no
[Why is the change risky/not risky?]: we've seen a drop in crashes in nightlies (but it's a bit hard to tell because it's low volume in the first place)
[String changes made/needed]: none
Attachment #8848534 - Flags: approval-mozilla-beta?
Comment on attachment 8848535 [details] [diff] [review]
Uplift three crash fixes to aurora

Approval Request Comment
[Feature/Bug causing the regression]: fallout from bug 1314514 where we made a crash less worrisome and reduced its volume
[User impact if declined]: low volume crashes
[Is this code covered by automated tests?]: no, we don't even know how this happens in the first place. One of the crash has a test upstream that we have disabled here because it takes too long, but we'll fix that soon (https://github.com/kinetiknz/cubeb/blob/master/test/test_overload_callback.cpp)
[Has the fix been verified in Nightly?]: yes, it's been landed for some time now
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: this is specifically prepared so that it can land on its own
[Is the change risky?]: no
[Why is the change risky/not risky?]: we've seen a drop in crashes in nightlies (but it's a bit hard to tell because it's low volume in the first place)
[String changes made/needed]: none
Attachment #8848535 - Flags: approval-mozilla-aurora?
Rank: 12
Priority: -- → P1
Comment on attachment 8848534 [details] [diff] [review]
Uplift three crash fixes to beta

Fix for a/v crash, let's uplift to beta. It may not land until Thursday's beta 6 build.
Attachment #8848534 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8848535 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8848109 - Attachment is obsolete: true
The Beta patch needs rebasing.
Flags: needinfo?(padenot)
This is rebased on top of current beta. I must have written the patch on top of
an old tree, sorry about that.
Attachment #8848534 - Attachment is obsolete: true
Fixed, sorry about that.
Flags: needinfo?(padenot) → needinfo?(ryanvm)
Flags: needinfo?(ryanvm)
Fixed in beta, we still may want to bring the one fix that affects esr52 into esr though.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1347453
Setting qe-verify- based on comment 5.
Flags: qe-verify-
Other than a conflict in update.sh that'd be trivial to rebase around, this grafts cleanly to esr52. Please request approval when you're comfortable doing so.
Flags: needinfo?(padenot)
Comment on attachment 8849533 [details] [diff] [review]
Uplift three crash fixes to beta

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: this fixes crashes
User impact if declined: it will crash a little bit more 
Fix Landed on Version: 53, 54, 55
Risk to taking this patch (and alternatives if risky): not really risky, we've landed that on a bunch of branches, and it does fix three different crashes (we've looked at crash-stats in the following days). 
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Flags: needinfo?(padenot)
Attachment #8849533 - Flags: approval-mozilla-esr52?
Comment on attachment 8849533 [details] [diff] [review]
Uplift three crash fixes to beta

cubeb crash fix for 52.1.0esr
Attachment #8849533 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
You need to log in before you can comment on or make changes to this bug.