Closed Bug 1347947 Opened 3 years ago Closed 3 years ago

Move static checking browser mochitests to their own folder

Categories

(Firefox :: General, defect)

54 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 55
Tracking Status
firefox55 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

We already have a few browser mochitests performing tests on all the files we are shipping. I think they deserve their own folder, as I'm going to add more soon (starting with bug 1316187).

The patch I will attach also does some cleanup to these tests:
- In browser_parsable_script.js I fixed location information for warnings from the JS parser, and made the test cover toolkit files in addition to browser files. (equivalent of the changes made in bug 1221383 to the css test)
- In browser_parsable_css.js I removed usage of Promise.jsm
- In browser_misused_characters_in_strings.js setting the xhr response type to text avoid lots of XML parse error in the terminal.

I changed parsingTestHelpers.jsm to a head.js file as it's really only needed for tests that will live in this folder, and all of them will need it.
Attached patch PatchSplinter Review
Attachment #8848095 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8848095 [details] [diff] [review]
Patch

Review of attachment 8848095 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but please also update https://dxr.mozilla.org/mozilla-central/source/tools/lint/eslint/modules.json#167
Attachment #8848095 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5df0025c79dc5cce54216194ab9ba8ddb38d222
Bug 1347947 - Move static checking browser mochitests to their own folder, r=Gijs.
https://hg.mozilla.org/mozilla-central/rev/b5df0025c79d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Duplicate of this bug: 1268535
You need to log in before you can comment on or make changes to this bug.