"editable" context in contextMenus API is not applied to some input fields.

RESOLVED DUPLICATE of bug 1345081

Status

RESOLVED DUPLICATE of bug 1345081
2 years ago
4 months ago

People

(Reporter: jura, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

778 bytes, application/zip
Details
(Reporter)

Description

2 years ago
Created attachment 8848523 [details]
bug.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

In a WebExtension I add a context menu using the following command:

chrome.contextMenus.create({"title": "Test menu item", "contexts": ["editable"]});

A sample extension is attached.



Actual results:

The menu item is displayed when I right mouse click on a regular input field, but the item is NOT displayed when clicking on input fields with the following values of the "TYPE" attribute of the "INPUT" element:
email, 
number, 
tel, 
url.

The



Expected results:

Since input fields of types "email, number, tel, url" are valid inputs for the "editable" context, the popup menu item should be displayed.
It works this way in Chrome.

Updated

2 years ago
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345081
(Reporter)

Comment 2

2 years ago
Not sure if it is correct to close this bug as duplicate to bug 1345081, since it only mentions the "tel" input type. Here I've listed all buggy inputs: "email, number, tel, url".
Just worry that "tel" will be fixed, but other cases are not fixed.

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.