Ebay embedded Paypal Checkout fails to load (spins forever) with NoScript and e10s DISABLED

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
8 months ago

People

(Reporter: zippy451, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-eBay][platform-rel-PayPal])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

without my permission this g. damn update was downloaded on me. now for 3 plus days i cannot buy with paypal

i am so so angry!!!! i have spent about 9 1/2 hours trying to fix this 

system restore took me back to previous version - everything worked again - but your damn update installed again. i am trying system restore again - 1st attempt failed - i do not want your updates ever again!!!!!

chrome works ok!


Actual results:

from ebay checkout i select "pay by paypal" - 1/2 screen paypal opens up - select acct now has a bloody key next to acct - click on acct - lock with circle spins - after 30 sec it jumps halfway off screen towards top and just keeps spinning - paypal says i am actually signed in, but i can go no further - can only back arrow, which takes me back to ebay checkout.


Expected results:

from ebay checkout i select "pay by paypal" - 1/2 screen paypal opens up - select acct now has a bloody key next to acct - click on acct - lock with circle spins - after 30 sec it goes to ebay checkout and lets me buy
Group: firefox-core-security

Updated

a year ago
See Also: → bug 1348498
platform-rel: --- → ?
Whiteboard: [platform-rel-eBay][platform-rel-PayPal]
(Reporter)

Comment 1

a year ago
WHAAAA....???


e machines pc

windows 7 home premium 64 bit

security add ons - ghostery, privacy badger, no script, http everywhere, disconnect, avast, ad block plus, better privacy, google disconnect. twitter disconnect, spybot, spybot anti beacon, 




is that a platform?, well if not i am back on my soapbox (platform) - i would vastlty prefer someone send me fix for firefox 52

failing that, detailed instructions for going back to firefox 50 with no pain - no losing bookmarks, no losing my security programs - last time i refreshed firefox i had to re install everything and it took half a day.

i'm old and terminally ill - a half a day is precious to me!!!!!
(Reporter)

Comment 2

a year ago
FIXED IT MYSELF!!!!

TRICK IS TO CLICK ON tiny MAXIMIZE button, REFRESH THE PAGE, ENTER LOG IN, WHILE THE DAMN CIRCLE SPINS REFRESH AGAIN - THEN IT GIVES YOU OPPORTUNITY TO PAY.


THIS IS AS CLOSE TO A FIX AS ANYONE HAS SUGGESTED! if you don't do this circle will spin and spin forever! who would have guessed?

Comment 3

a year ago
Rares can we have some exploratory testing around trying to reproduce this?
Flags: needinfo?(rares.bologa)

Comment 4

a year ago
(In reply to Benjamin Smedberg [:bsmedberg] from comment #3)
> Rares can we have some exploratory testing around trying to reproduce this?

Sure. Roxana will look into this one (it also shows up in our Outstanding list).
Flags: needinfo?(rares.bologa) → needinfo?(roxana.leitan)
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751


I have tested this issue on Windows 7 x64 with the latest Firefox release (52.0)and managed to reproduce it after I installed the extensions: "No Script Security Suite Developer" and "Avast SafePrice".
After I select "Pay with PayPal" and click "Log In to PayPal" button, appears a never ending spinning wheel.

I also tried the steps from comment 2 and if I maximize the page (PayPal window pop-up) the issue is not reproducible anymore.
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 6

a year ago
fyi it was never ending spinning with no script disabled and greyed out.


maximizing the half window was not an option - that was the problem - it was blocking me from maximizing - the little button would turn solid blue and the half window would freeze - it would still allow the main page back arrow - and most importantly i later found out the main page refresh. that main page refresh done whilst the wheel spun was the eventual fix that lets me proceed to the full window.
(Reporter)

Comment 7

a year ago
i am so frustrated i have blocked further updates, and don't even want to know about them!

i noticed someone - probably from mozilla - said an undo feature would be wasting too much time. well whoever that was it is to you i say you didn't mind wasting between 15 -18 hours of my time trying to recover from this firefox 52 update!

this whole mess was foisted off on me in my sleep - i awoke with "you're connection has been reset" on my screen. from there the nightmare began.
Summary: security update 52.0 has broken ebay paypal checkout! → ebay paypal checkout broken in 52 with NoScript and Avast SafePrice
Duplicate of this bug: 1348498

Comment 9

a year ago
Jorge, who owns next steps here?
Flags: needinfo?(jorge)
Roxana, can you confirm that this only happens with both add-ons installed?
Flags: needinfo?(jorge) → needinfo?(roxana.leitan)
Hi Jorge,

I can reproduce the issue only with both add-ons installed and enabled.
Flags: needinfo?(roxana.leitan)

Comment 12

a year ago
Hi all,

please take a look to this forum / thread:

https://forums.informaction.com/viewtopic.php?f=7&t=22641

There is no "AVAST" installed, same bug.
(Reporter)

Comment 13

a year ago
firefox must include an undo feature with every update, especially since these are foisted off on people in the middle of the night without permission. i went to the 3 grey bars on upper right of screen/ select options / select advanced / select never check for updates - - i am so frustrated with firefox i really don't even want to know about their gosh dern updates again.
It looks like it's caused by NoScript, and Giorgio is looking into it. The forum thread in comment #12 has more details, including a potential workaround.
(Reporter)

Comment 15

a year ago
uuuhhhh... wrong

i tried with no script disabled - no effect on the ever spinning wheel!

AND - even if it was no script, it worked with fox 51, so why not 52 - imho firefox 52 is to blame and sorely needs a patch, AND a bloody undo button.

Comment 16

a year ago
Hm, do You realy DISABLED NoScript (not only script blocking)?
Try to disable the whole AddOn NoScript on FF AddOn site and restart FF.

This works every time for some users (and me).
Else use the workaround (right click on spinning wheel and "open frame in new tab").

And You are right - the changes and updates in FF in the last month often do some misterious things with my FF configuration too...
(Reporter)

Comment 17

a year ago
thanks for answer.

i love no script, perhaps more than ff. i will assume you are correct though. i will continue to use my work around - refreshing the page while the wheel spins - and continue blocking more updates until i see an undo feature.

mozilla is in the process of creating another linux user.

Comment 18

a year ago
Hello Everyone, 

The Ebay to Paypal "handshake" doesn't complete with Firefox 52.0.2 

The process completes with 51.0.1 (32 bit) installed and I do have Avast and NoScript installed. I manually 
enable/allow Paypal and it's related sites in NoScript when I go through the Ebay payment process... it has 
always worked before and continues with 51.0.1 

My other exact same model & OS computer with the latest 52.0.2 update is where the problem lies.  
Firefox 52.0.2 has changed enough that whatever handshake method used with 51.0.1 (and still works 
as of 10 minutes past) was broken or disabled.  

So, I'm going to keep this computer at 51.0.1 until and or if a fix becomes available. 

cheers, 

skipp025 at jah who period calm
(Reporter)

Comment 19

a year ago
i think i got the solution, i am not sure how it works, but it adds stability to the handshaking! just install this app: 

https://addons.mozilla.org/En-uS/firefox/addon/autocomplete-forms-for-firefox/ 

ff52 seems to have affected the autocomplete feature on some sites. also gives trouble when highlighting a phrase to add to the clipboard. with this app installed all goes smoother. still a step back from ff51.

Comment 20

a year ago
A Temporary work around is to DISABLE No-Script under Tools/Add-ons and restart Firefox. Complete the Ebay/Pay Pal checkout process then go back and Re-enable No-Script when you are finished with Ebay.  Setting No Script to allow scripts globally will not help. You must completely disable the add-on for this work around.  I hope this bug gets fixed soon.

Comment 21

a year ago
There are two easier workarounds.

On PayPal login frame you can:

1.
If there is an button to maximize the frame (lower right corner a little arrow):
You can click there and it still works.

2.
If there is no button to maximize the window (this is the actual style for me):
Right click in the popup and choose "actual frame - show in new tab".
Works perfect.

But of course: this is an bug that MUST be solved.
Can't seach for a workaround at any checkout which wont work...

Comment 22

a year ago
In regards to Joe G's "work around is to disable no-script"... that doesn't fix or work around the 
problem, I believe I tried that without success. Where I absolutely needed to complete the Ebay 
Paypal checkout process, I simply found and reinstalled the previous version of Firefox 51 and 
finished. 

I noticed that Firefox 52.0.2 is now out, don't know what the difference and/or fix is. I installed 
the non 52 esr 32-bit version on an XP machine and it works just fine, no problems noticed yet. 
Although I have not yet tried the 52.0.2 (non esr) XP version with a Paypal transaction yet. The 
other trick is with XP, you have to manually go after the non ESR version from a download site 
because all the regular methods of updating and web searching will detect your XP system and auto 
steer you to download the ESR version. So, pay attention, figure out how to find and download the 
non ESR Firefox 52.0.2 (or newer) and give it a try. 

Good luck and enjoy...

cheers, 

skipp025 at ya who dot com

Comment 23

a year ago
The bug is not OS-depending.

Same bug on Linux or win 7 / xx is reported.

That FF 51 works ist an old solution.
That FF 52 non ESR works without this bug is NEW - for my understanding it is the same version as the ESR, only the update channel is an other.
platform-rel: ? → -

Comment 24

a year ago
> The bug is not OS-depending.
> Same bug on Linux or win 7 / xx is reported.

Hopefully someone will work on the solution 

> That FF 51 works ist an old solution.

If you're not able to pay for your Ebay purchases, Ebay starts a very 
demanding dialog after only one or two days. I believe this problem is 
going to extend out for quite some time. So the retro back to version 
51 is a fix that works for the near term. 

> That FF 52 non ESR works without this bug is NEW - for my 
> understanding it is the same version as the ESR, only the 
> update channel is an other. 

You miss understood my intent...  I was trying to indicate that 
the non ESR 52 does install and work with Windows XP. I have not 
tried or verified anything related to the original Paypal broken 
link/hand-off problem with Windows XP and FF 52 non ESR. When 
FF updated my 51 browser to 52ESR is when I experienced the current 
problem. I have not tried the same Ebay to Paypal process with 
ESR non 52. 

Cheers, 

skipp025 at yah who period com
(Reporter)

Comment 25

a year ago
this bug is making me buggy! sometimes i think i get it, but then the work around stops working. sometimes now, like when buying postage, checkout uses different pages and goes through fine.

now when buying i am using chrome most of the time.

best work around to date; right click on the half page choose payment page, and choose open in new tab. fill that page out and when the circle just keeps spinning just refresh the whole page. it usually handshakes, and you are set to buy.

my idea about forbidding further updates is bad. it would prevent ff53 which may include fixes. once i get a version that isn't buggy i am indeed blocking updates. i don't seem to be able to go back to ff51. i tried. i have a cd-rom of it, but do not know what to do. unfortunately i am self educated and not all knowing. i tried to get ubuntu. again i got a dang disc and don't know what to do. i hear your supposed to boot from that cd????? does this mean i must shut down & reboot with that cd in the drive????? do i really need to partition the drive???? how???? 

make my reservation. i am off to see the men in the white coats....

Comment 26

a year ago
Your posts hint that you seem to make extra work for yourself. If you don't want to 
deal with what ever weird work around you have for the Firefox 52 to Paypal hand-shake 
issue, then simply download and reinstall Firefox 51 right back over the top of 52, 
it will overlay and retro 52 back to 51 just fine. Here's the URL to download what 
ever version you want/need to install. 

https://ftp.mozilla.org/pub/firefox/releases/51.0/ 

Once you're back up with 51, get on with your life and wait to see if 52.x.x or 53.x.x 
versions fix the failed hand off issue. 

That is all, now resume all skate. All skate in the normal direction. 


s.

Comment 27

a year ago
There is a hint in the other forum.
It works for me, but I don't knew if it will give other trouble with addons:

NoScript and Firefox v52.0 breaks ebay / paypal checkout
Post by mstrcb

"There's a really simple way to fix the problem:

Cause of the problem occuring in FF52 / 53: After installing the FF update, the multipocessor feature (aka "e10s") is disabled. This seems to cause the problem to occur.

Solution: just set the about:config variable browser.tabs.remote.force-enable to true (if it doesn't exist (anymore): just create it as boolean)"

Comment 28

a year ago
I have switched to uMatrix (and delete NoScript - sorry).

And have solved this problem.

As you can see in the in the Matrix of this AddOn, there are many more urls from Ebay and PayPal, which have to set on the whitelist.
NoScript never see or offer them to whitelisting...

uMatrix is (for me) the better solution, it offers an better UI.

Comment 29

a year ago
FF 53.0.3 32 bit with NoScript still has this prolem
Win7 64 bit

The workaround (right click on spinning wheel and "open frame in new tab") worked for me

Comment 30

a year ago
I just reproduced this on FF 52.2.0 on Redhat Enterprise 6.8.  Disabling NoScript and restarting FF allowed me to check-out on ebay.

Comment 31

a year ago
This happens on Linux in 52.2.0 ESR too, with noscript but no Avast (so the bug summary is wrong, should probably not mention Avast).

I worked around it by bringing up a firefox with a vanilla profile (noscript not installed) in private mode just to log in to ebay and complete the transaction. An unsatisfying workaround since it's a lot more steps and there's no password autofill.

Comment 32

a year ago
Still happens on Firefox 54.0; Linux Mint 18.1 (Serena) based on Ubuntu 16.04

Issue is with Paypal and NoScript.  Whitelisting Paypal.com and paypalobjects.com allows work around to function.

Workaround 1: Remove NOSCRIPT.  NOTE: DISABLING NOSCRIPT does NOT work.  NOSCRIPT must be COMPLETELY REMOVED from firefox for the transaction to complete without the workaround.  

Workaround 2: After login to paypal, open the pop up in a new tab.
* After login attempt, pop up window displays a spinning wheel forever. [the window actually updates, and displays the spinning wheel at the top of the window, such that the top half of the spinning wheel is chopped off, and spins forever]
* Right click in the pop up
* Select open frame in new tab
* Transaction now completes.

Comment 33

a year ago
Can we change the title of this bug to something more likely to come up in a google search, like "Firefox PayPal checkout Broken, login spins forever" ?

It took me months to find this report and get the workaround, because I did not realize the issue was with noscript, and I do not have avast safeprice (which is not part of the issue anyway, it seems).

Updated

a year ago
Summary: ebay paypal checkout broken in 52 with NoScript and Avast SafePrice → ebay paypal checkout broken in 52, spins forever

Updated

a year ago
Summary: ebay paypal checkout broken in 52, spins forever → ebay paypal checkout broken in 52 with NoScript, spins forever
All the details I've been able to gather and reproduce so far:

1. This happens only if NoScript is installed AND multi-process windows (Electrolysis AKA e10s) are DISABLED (therefore any e10s-incompatible add-on, such as Avast as originally reported, triggers this bug by disabling e10s)
2. The bug apparently causes the frame where the Paypal checkout would be loaded in "embedded mode" to simply fail to load, but so far I could not find the actual NoScript feature triggering (even disabling all the major ones the frame keeps aborting just before being parsed).
3. The sanest work-around would be enabling/forcing e10s
4. Any other work-around involves either disabling NoScript or causing the checkout page to be loaded in its own top-level window (I've seen this happening in a popup during my tests even "spontaneously", not sure what triggers it; otherwise "Open this frame in another window" could be used).

We're still investigating, even if in a couple Firefox version this will be moot for most users, mainly because of ESR and the  Tor Browser (to a lesser extent, since Tor and Paypal usually don't mix well).
Summary: ebay paypal checkout broken in 52 with NoScript, spins forever → Ebay embedded Paypal Checkout fails to load (spins forever) with NoScript and e10s DISABLED

Comment 35

a year ago
Giorgio Maone: What are "multi-process windows (Electrolysis AKA e10s)"? I and quite a few others are seeing this without Avast (I had never heard of Avast prior to this bug report; apparently it's a Windows thing?) I agree with "prof_braino" that the bug is hard to find when it has these specialized extensions mentioned in the summary when the extensions aren't necessary in order to see the bug.
(In reply to Akkana Peck from comment #35)
> Giorgio Maone: What are "multi-process windows (Electrolysis AKA e10s)"? I
> and quite a few others are seeing this without Avast 

https://wiki.mozilla.org/Electrolysis

It should be enabled by default in recent Firefox versions, unless you've got incompatible extensions, which cause Firefox to automatically disable it.

It can be forced to enabled for testing purposes this way: https://wiki.mozilla.org/Electrolysis#Force_Enable

Comment 37

a year ago
Thanks, Giorgio. And is there any way to find out (short of removing all add-ons one by one, restarting each time then checking about:support) which add-on is disabling it, since you seem to be saying the culprit is something other than NoScript? That would go a long way toward giving people a workaround.

Comment 38

8 months ago
With Firefox 57, all add-ons are WebExtensions and e10s compatible.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.