Closed Bug 13486 Opened 20 years ago Closed 20 years ago

Apprunner crashes when scrolling on the folder pane

Categories

(MailNews Core :: Backend, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 13483

People

(Reporter: marina, Assigned: hyatt)

Details

Steps to reproduce:
-open Messenger (apprunner -mail)
-open one of your accounts (i have three);
- to get to the last folder(i have 10 folders) of my third account i need to
scroll the bar down
//note: apprunner crashes
****0bserved with 1999-09-09 windows build****
Assignee: phil → putterman
Summary: Apprunner crashes when scrolling on the left thread pane → Apprunner crashes when scrolling on the folder pane
Reassign to putterman, fix summary
Assignee: putterman → hyatt
reassigning to hyatt.  This is the stack I get:

nsGenericElement::Release(nsGenericElement * const 0x045c7508) line 1207 + 12
bytes
nsJSUtils::nsGenericResolve(JSContext * 0x0403f510, JSObject * 0x03cf6ae8, long
35495596) line 532 + 12 bytes
ResolveElement(JSContext * 0x0403f510, JSObject * 0x03cf6ae8, long 35495596)
line 165 + 17 bytes
_js_LookupProperty(JSContext * 0x0403f510, JSObject * 0x03cf6ae8, long 50208160,
JSObject * * 0x0012ebb0, JSProperty * * 0x0012eba8, const char * 0x0104cd5c,
unsigned int 1669) line 1507 + 24 bytes
js_GetProperty(JSContext * 0x0403f510, JSObject * 0x03cf6ae8, long 50208160,
long * 0x0012f208) line 1669 + 35 bytes
js_Interpret(JSContext * 0x0403f510, long * 0x0012f388) line 2184 + 978 bytes
js_Invoke(JSContext * 0x0403f510, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x0403f510, JSObject * 0x03cf63b8, long 63923136,
unsigned int 1, long * 0x0012f4a4, long * 0x0012f50c) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x0403f510, JSObject * 0x03cf63b8, long
63923136, unsigned int 1, long * 0x0012f4a4, long * 0x0012f50c) line 2662 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x047d13d0) line 110 + 43 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012f8e4, nsIDOMEvent * * 0x0012f88c, unsigned int 2, nsEventStatus &
nsEventStatus_eIgnore) line 621 + 21 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x0453ba60, nsIPresContext
& {...}, nsEvent * 0x0012f8e4, nsIDOMEvent * * 0x0012f88c, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2867
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x04558470, nsIPresContext
& {...}, nsEvent * 0x0012f8e4, nsIDOMEvent * * 0x0012f88c, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2871 + 39 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x045cf740, nsIPresContext
& {...}, nsEvent * 0x0012f8e4, nsIDOMEvent * * 0x0012f88c, unsigned int 2,
nsEventStatus & nsEventStatus_eIgnore) line 2871 + 39 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext & {...}, nsEvent * 0x0012f8e4,
nsIDOMEvent * * 0x0012f88c, unsigned int 1, nsEventStatus &
nsEventStatus_eIgnore) line 789 + 39 bytes
AnonymousElement::HandleDOMEvent(AnonymousElement * const 0x045c74fc,
nsIPresContext & {...}, nsEvent * 0x0012f8e4, nsIDOMEvent * * 0x00000000,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 130 + 31 bytes
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0x0454de80, nsIPresContext & {...}, nsMouseEvent * 0x0012fbe4, nsEventStatus &
nsEventStatus_eIgnore) line 864 + 31 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x0454de80,
nsIPresContext & {...}, nsGUIEvent * 0x0012fbe4, nsIFrame * 0x045d2d40,
nsEventStatus & nsEventStatus_eIgnore, nsIView * 0x04066e00) line 393 + 24 bytes
PresShell::HandleEvent(PresShell * const 0x04066754, nsIView * 0x04066e00,
nsGUIEvent * 0x0012fbe4, nsEventStatus & nsEventStatus_eIgnore) line 2005 + 43
bytes
nsView::HandleEvent(nsView * const 0x04066e00, nsGUIEvent * 0x0012fbe4, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 835
nsViewManager::DispatchEvent(nsViewManager * const 0x04065330, nsGUIEvent *
0x0012fbe4, nsEventStatus & nsEventStatus_eIgnore) line 1612
HandleEvent(nsGUIEvent * 0x0012fbe4) line 67
nsWindow::DispatchEvent(nsWindow * const 0x04066cc4, nsGUIEvent * 0x0012fbe4,
nsEventStatus & nsEventStatus_eIgnore) line 332 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fbe4) line 353
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=???
y=???}) line 3154 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=???
y=???}) line 3372
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 15859958, long *
0x0012fe04) line 2388 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x000104ca, unsigned int 514, unsigned int 0, long
15859958) line 401 + 27 bytes
USER32! 77e71250()
00f200f6()
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13483 ***
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.