Closed Bug 1348625 Opened 5 years ago Closed 5 years ago

Crash in JS::GCCellPtr::is<T>

Categories

(Core :: XPCOM, defect)

54 Branch
x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1216776

People

(Reporter: baffclan, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-047c3f2a-e292-450b-b450-797762170319.
=============================================================


Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	JS::GCCellPtr::is<JSObject>() 	obj-firefox/dist/include/js/HeapAPI.h:183
1 	xul.dll 	mozilla::JSGCThingParticipant::TraverseNative(void*, nsCycleCollectionTraversalCallback&) 	xpcom/base/CycleCollectedJSContext.cpp:309
2 	xul.dll 	CCGraphBuilder::BuildGraph(js::SliceBudget&) 	xpcom/base/nsCycleCollector.cpp:2282
3 	xul.dll 	nsCycleCollector::MarkRoots(js::SliceBudget&) 	xpcom/base/nsCycleCollector.cpp:2878
4 	xul.dll 	nsCycleCollector::Collect(ccType, js::SliceBudget&, nsICycleCollectorListener*, bool) 	xpcom/base/nsCycleCollector.cpp:3665
5 	xul.dll 	nsCycleCollector_collectSlice(js::SliceBudget&, bool) 	xpcom/base/nsCycleCollector.cpp:4170
6 	xul.dll 	nsJSContext::RunCycleCollectorSlice() 	dom/base/nsJSEnvironment.cpp:1487
7 	xul.dll 	ICCTimerFired 	dom/base/nsJSEnvironment.cpp:1545
8 	xul.dll 	nsTimerImpl::Fire(int) 	xpcom/threads/nsTimerImpl.cpp:479
9 	xul.dll 	nsTimerEvent::Run() 	xpcom/threads/TimerThread.cpp:297
10 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1264
11 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/threads/nsThreadUtils.cpp:389
12 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:124
13 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:231
14 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:211
15 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp:156
16 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp:263
17 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp:283
18 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp:4492
19 	xul.dll 	XREMain::XRE_main(int, char** const, mozilla::BootstrapConfig const&) 	toolkit/xre/nsAppRunner.cpp:4670
20 	xul.dll 	mozilla::BootstrapImpl::XRE_main(int, char** const, mozilla::BootstrapConfig const&) 	toolkit/xre/Bootstrap.cpp:45
21 	firefox.exe 	NS_internal_main(int, char**, char**) 	browser/app/nsBrowserApp.cpp:307
22 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:115
23 	firefox.exe 	__scrt_common_main_seh 	f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253
24 	kernel32.dll 	BaseThreadInitThunk 	
25 	ntdll.dll 	RtlUserThreadStart 	


Application Basics: 
Name: Firefox
Version: 54.0a2
Build ID: 20170318004003
Update Channel: aurora
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Component: JavaScript Engine → XPCOM
Andrew, ideas?
Flags: needinfo?(continuation)
This looks like some kind of memory corruption issue. I guess it could be something else.

Do you get this crash regularly? Are you overclocking your computer or anything like that?
Flags: needinfo?(continuation)
See Also: → 1346417
See Also: 1346417
If you have steps to reproduce, please needinfo me. For now, I'm just going to dupe it to another existing issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1216776
You need to log in before you can comment on or make changes to this bug.