Closed Bug 1348630 Opened 3 years ago Closed 3 years ago

Allow Plug-ins to Run In-Process

Categories

(Core :: Plug-ins, defect, critical)

52 Branch
All
Windows
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ascii.elite, Unassigned)

Details

As of Firefox 43, support for running plug-ins in process was disabled or removed again (See bug 1194780 ( https://bugzilla.mozilla.org/show_bug.cgi?id=1194780 )) for the give reason:
"CHANGE: In preparation for multi-process content in future releases, single-process mode is no longer supported for NPAPI plugins. The preferences under dom.ipc.plugins are no longer used." (Benjamin Smedberg, bug 1194780).

This change has come rather prematurely and should be reverted until at least the discontinuation of support for Windows XP.


Please take note of the following considerations:
1. Mozilla Firefox is supposed to support Windows XP and Windows Vista through Firefox 52.

2. Using plug-ins out-of-process was first introduced in Firefox 3.6.4.

3. Mozilla had removed the ability to disable the use of plug-in container once before Firefox 43 and later restored the ability (I forgot for what release(s)). I do recall that the ability to disable the use of plug-ins out-of-process (using plug-in container) was not available in Firefox 17.0.  I am uncertain what the Bugzilla bug reference or references are regarding these changes.

4. The (multi-process) out-of-process model implementation as it relates to plug-ins (using a plugin-container) has never been stable on Windows 2000, Windows XP, or Windows Server 2003 family operating systems. On Windows XP family operating systems, browser hangs, slowdowns, high CPU usage, high memory usage, window and content drawing or positioning errors, and plug-in performance related trouble could often be experienced when a separate (plugin-container) process is used. The problem would also often be made worse when windows management software (including multi-monitor management software) were also used. On Windows 2000 family operating systems, the plugin-container would never run or be used.

5. Although not as critically affected as Windows XP and Windows Server 2003 family operating systems, Firefox on newer Windows operating systems still may incur some of the troubles also incurred by on Windows XP described in point "4." above.

6. There recently were ways to disable the out-of-process plugin plugin-container use and rely on the plug-in running in the Firefox process, but those ways are no longer available due to the change implemented for bug 1194780.


Comments and Conclusions:
The use of the plug-in container severely and critically cripples the reliability and usability of Firefox on Windows XP and Windows Server 2003. It is important to be able to opt not to use the plug-ins out-of-process and be able to use the plug-ins.

The reasons and arguments for the restoration of the ability to disable the use of plug-ins out-of-process after the first time Firefox was released with such ability removed (described in point 2 above) still apply today.

As an extra, but related note, it appears that Mozilla is aware of stability issues with Windows XP and the new Electrolysis multi-process model. Its solution was to exclude it (and Windows Vista) from using Electrolysis multi-processes (Source: https://wiki.mozilla.org/Electrolysis#Windows_XP ). Significant stability issues appear to be present regardless as to which multi-process model (Electrolysis or plugin-container) is used for Firefox on Windows XP. It would be desirable to not be forced to use one of the known troublesome models.


Request:
Revert the changes from bug 1194780 or otherwise provide for the use of plug-ins not out-of-process until Windows XP support has ended.
Given that support for Windows XP and Windows Vista is to end at the end of ESR Firefox (bug 1303827), I would further request that this be given high priority.
Component: Untriaged → Plug-ins
Product: Firefox → Core
Target Milestone: Firefox 52 → ---
Benjamin, what's the plan of Mozilla about this subject?
Flags: needinfo?(benjamin)
No, we're not going to support this. OOP plugins work in general on XP/Vista.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(benjamin)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.