New container tab content should not show template placeholders

RESOLVED INVALID

Status

()

Core
DOM: Security
RESOLVED INVALID
11 months ago
11 months ago

People

(Reporter: sole, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
Created attachment 8849037 [details]
Screen Shot 2017-03-20 at 09.45.06.png

When I create a new container tab I get these placeholders instead of the content I'd expect (see screenshot).

Using Nightly 20170319 on Mac Os X.

I noticed this right after I created my own container and then created a tab using it, I don't know if this was the case before. I tried with other container types and now I get the placeholders when creating all types of containerised tabs.
(Reporter)

Updated

11 months ago
Blocks: 1191418
That screenshot shows activity stream. Sounds like the two experiments don't play well together. It could just as easily be an AS bug as a container bug, in fact that might be more likely because if you just created a new container there is no data in it, it's as if you just created a new profile. What does Activity Stream do in a brand new fresh profile? That's probably what it should do in a new container.

Once you use a particular container a bunch I'd expect that page to be populated with the activity stream appropriate to that container. For example, you wouldn't want your "Social" tab to be filled up with your most used work and banking sites, you want your social activities to show up.
Flags: needinfo?(sole)
(Reporter)

Comment 2

11 months ago
Ohhh you're right. I do not know what does AS do on a new profile. I can't test it right now, so I will just close this as invalid. I'll report on the AS forum though. Thanks!
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(sole)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.