Closed Bug 1348860 Opened 4 years ago Closed 4 years ago

Large number of youtube videos not playing audio

Categories

(Core :: Audio/Video: cubeb, defect)

52 Branch
All
Linux
defect
Not set
major

Tracking

()

RESOLVED INVALID
Tracking Status
firefox55 --- affected

People

(Reporter: wgianopoulos, Unassigned)

Details

The audio no longer plays on many youtube videos I try to play under Linux sice it has started being built without alsa support.

Here si and example

https://www.youtube.com/watch?v=uHfB63ln1Ig
Version: Trunk → 52 Branch
Summary: Not permitting alsa on Linux results in a large number of youtube videos nottpalying audio → Not permitting alsa on Linux results in a large number of youtube videos not tpalying audio
Summary: Not permitting alsa on Linux results in a large number of youtube videos not tpalying audio → Not permitting alsa on Linux results in a large number of youtube videos not playing audio
Status: NEW → RESOLVED
Closed: 4 years ago
Component: General → Audio/Video: cubeb
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1345661
I am not sure I buy this being a duplicate.  The system I a seeing this issue on has pulseaudio installed.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Bill Gianopoulos [:WG9s] from comment #2)
> I am not sure I buy this being a duplicate.  The system I a seeing this
> issue on has pulseaudio installed.

Then what does it have to do with "Not permitting alsa"? What versions does this affect (nightly? release? both?)? When did it start happening? Can you give examples of working and not-working youtube videos? Have you verified that the broken ones start working again when you build *with* alsa support?
Flags: needinfo?(wgianopoulos)
Summary: Not permitting alsa on Linux results in a large number of youtube videos not playing audio → Large number of youtube videos not playing audio
This actually started with my own current mozilla-central build built on a system that has both alsa and pulseaudio installed.  The referenced (and some other youtube videos) did not play audio.  Re-doing the build with "ac_add_options --enable-alsa" resulted in working audio.
Flags: needinfo?(wgianopoulos)
This is all coming back to me.  It seems to me I filed a similar bug about pulseaudio years ago and it was some kind of issue about sample rates outside the range of what the hardware supports.  I don't remember the final outcome of the bug. I fear it may have been install alsa.  I am not feeling well so turning in early for the night.  I will get back to this in the morning.

I will try to find my old bug and produce debugging output similar to what I did last time to tack the issue down.
I found the old bug it was bug 704993 which seems to have been fixed in alsa.  I wonder if the issue is now coming up in pulseaudio.
OK I have no idea what is going on here.  All I have figured out is the my correlation with alsa or not was invalid.  On builds with alsa support or without sometimes the audio plays and sometimes it does not.  I will refile this if I get more info about what the real issue is. 

For now >> INVALID
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.