Closed Bug 1349149 Opened 3 years ago Closed 3 years ago

stylo: Build failure in geckoservo crate with rustc 1.16.0

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: TYLin, Assigned: manishearth)

References

Details

(Keywords: regression)

I got the following error message when building stylo after upgrading rustc to 1.16.0.

 5:35.36    Compiling geckoservo v0.0.1 (file:///Users/tlin/Projects/gecko-dev/servo/ports/geckolib)
 5:35.99 error: unused `#[macro_use]` import
 5:35.99   --> /Users/tlin/Projects/gecko-dev/servo/ports/geckolib/lib.rs:10:1
 5:35.99    |
 5:35.99 10 | #[macro_use] extern crate lazy_static;
 5:35.99    | ^^^^^^^^^^^^
 5:35.99    |
 5:35.99 note: lint level defined here
 5:35.99   --> /Users/tlin/Projects/gecko-dev/servo/ports/geckolib/lib.rs:5:9
 5:35.99    |
 5:35.99 5  | #![deny(warnings)]
 5:35.99    |         ^^^^^^^^
 5:35.99 
 5:36.00 error: aborting due to previous error
 5:36.00 
 5:36.02 error: Could not compile `geckoservo`.

I'll upload a PR to servo/servo.
FWIW, I have the following in my MOZCONFIG.

ac_add_options --enable-debug
ac_add_options --disable-optimize
Probably a recent regression. Stylo builds fine with Rust 1.16.0 before mozilla-central changeset e3e83e6bf409 or https://github.com/servo/servo/commit/1bacd0eb1582
Blocks: 1335941
Keywords: regression
This should be fixed by https://hg.mozilla.org/integration/autoland/rev/68e06a8f32fb
Assignee: tlin → nobody
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.