to be a link or not to be... that´s the right click question...

VERIFIED DUPLICATE of bug 23485

Status

SeaMonkey
Location Bar
--
enhancement
VERIFIED DUPLICATE of bug 23485
17 years ago
10 years ago

People

(Reporter: mike lima, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020222
BuildID:    2002022203

If you look at the bottom of the page above you will see something that can be
improved...

At the bottom of the page there is a link

http://msdn.microsoft.com/developer/downloads/files/
40comupd.htm. 

that link is written in two lines, as above but is not shown as a link.
So you will have to do 2 copy and paste and to go to taht URL.

So, 3 things could be done by you guys...

1) put a box on preferences where one can turn on all links to be a link even if
no one puts it as a link  or

2) give mozilla the ability to read the clipboard and see that link in two
lines, converting it to a one line when one issues a CONTROL V on address line

3) give an option on right click, as GOTO ADDRESS "BLA BLA"  as the one which
says SEARCH GOOGLE for "bla bla".

think about that as your homework... :-)

regards,




Reproducible: Always
Steps to Reproduce:
1.go to the URL...
2.
3.

Actual Results:  boring...

Expected Results:  coolness!

nothing to say...
This feature request is already filed (bugs exist covering all three approaches).

And a webmaster who gives <a> a target but not an href should be shot on sight...
Whiteboard: DUPEME

Comment 2

17 years ago
2) bug 23485 browser window should strip newlines from url pastes
3) bug 10080 [RFE] Recognition of highlighted text as URL

I don't see a bug on #1, but it's a bad idea for the same reason as #3: it would
increase the number of non-hyperlinked urls in web pages because web authors
would forget to put in hrefs.

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 23485 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Product: Core → SeaMonkey

Updated

14 years ago
Status: RESOLVED → VERIFIED
Component: General → Location Bar
Product: Mozilla Application Suite → Core
QA Contact: matti → benc
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.