Save of JSON from JSONviewer doesn't work/save file to location/folder/directory

VERIFIED FIXED in Firefox 54

Status

()

Firefox
Developer Tools: JSON Viewer
VERIFIED FIXED
a year ago
10 months ago

People

(Reporter: Harald, Assigned: baku)

Tracking

unspecified
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54+ fixed, firefox55 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Nightly on OSX.

Tried to save a JSON file (700kb) using the Save button. No file appeared in the target folder. Could not find any related error on the Browser Toolbox.
[Tracking Requested - why for this release]: Broken feature exposed by UI (brokenness might be noticed with delay).

This is a regression from bug 1334975 / https://hg.mozilla.org/mozilla-central/rev/5ed300efb2fa#l5.1

baku, can you take a look at this, please?
Blocks: 1334975
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox-esr45: --- → unaffected
status-firefox-esr52: --- → unaffected
tracking-firefox54: --- → ?
Flags: needinfo?(amarchesini)
Summary: Save doesn't work → Save of JSON from JSONviewer doesn't work/save file to location/folder/directory
(Assignee)

Updated

a year ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
(Assignee)

Comment 2

a year ago
Created attachment 8849990 [details] [diff] [review]
jsonview.patch
Attachment #8849990 - Flags: review?(kyle)

Comment 3

a year ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a49f28a2a6a
Fixing the saving in the JSONviewer, r=qdot

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5a49f28a2a6a
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox55: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Please request aurora uplift when you get a chance.  (Also kind of surprised this isn't covered by automated tests?)
tracking-firefox54: ? → +
Flags: needinfo?(amarchesini)
(Assignee)

Comment 6

a year ago
Comment on attachment 8849990 [details] [diff] [review]
jsonview.patch

Approval Request Comment
[Feature/Bug causing the regression]: Bu1334975 
[User impact if declined]: JSONView save feature is broken
[Is this code covered by automated tests?]: none
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: yes. Just try to save a JSON from the JSONView.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no. 
[Why is the change risky/not risky?]: I just forgot a 'then' in the previous patch.
[String changes made/needed]: none
Flags: needinfo?(amarchesini)
Attachment #8849990 - Flags: approval-mozilla-aurora?
Hi :Harald, could you help check if this issue was fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(hkirschner)
Comment on attachment 8849990 [details] [diff] [review]
jsonview.patch

Confirmed working for me in today's nightly, broken in aurora, let's uplift this.
Flags: needinfo?(hkirschner)
Attachment #8849990 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 9

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/f677f6052b9f
status-firefox54: affected → fixed

Comment 10

10 months ago
I managed to reproduce the bug on Nightly from 2017-03-21. Then I tested using this JsonView (https://jsonview.com/example.json) and the files were successfully saved.  I used the latest Nightly and Firefox 55.0b13 on Windows 10 x64, Ubuntu 16.04 x64 and on Mac OS x 10.11 and the issue seems to be fixed.
Thanks for verifying.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
You need to log in before you can comment on or make changes to this bug.