Closed Bug 1349597 Opened 3 years ago Closed 3 years ago

Add telemetry tests to marionette job

Categories

(Toolkit :: Telemetry, enhancement, P4)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1358670

People

(Reporter: Silne30, Assigned: Silne30)

References

Details

(Whiteboard: [mach])

We need a mach command to run telemetry tests. Needs to install dependencies, run tests and report results.
Blocks: 1301776
Priority: -- → P4
Assignee: nobody → jdorlus
Whiteboard: [mach]
From https://hg.mozilla.org/mozilla-central/rev/ea85026945a7, it appears these "telemetry tests" are just a special flavor of Marionette test. Since the special sauce is handled by the Marionette/Python test class, there doesn't need to be any special handling of these tests in mach or even automation: as long as the test manifests are declared in moz.build files, everything should "just work."

The only special casing I could see us wanting is a dedicated automation task for running just these tests. But I don't think that is needed initially.

Test manifests allow you to create a "tag" for tests. So using that, you can easily run "telemetry tests" with e.g. `mach test --tag telemetry` or `mach marionette-test --tag telemetry`.
Changing name of task based on feedback from :gps
Depends on: 1358670
Summary: Create Mach Command for Telemetry Tests → Add telemetry tests to marionette job
Status: NEW → ASSIGNED
This is a duplicate of 1358670 being that this started as just being for a mach command. A mach command was not what we needed. We need a telemetry-tests to have their own job in automation which is handled in the aforementioned bug. Should we need a mach command in the future, we will open a new bug.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358670
You need to log in before you can comment on or make changes to this bug.